Release of 0.3.0

edited October 2017 in General

Dear all,

We have just released a new platform version with a lot of new features and improvements. The most prominent ones are probably:

  • Added support for the TWRP recovery (accessible through the "Power Off" application or "reboot recovery")
  • Included a number of different USB-WIFI drivers for CM3-based devices
  • Fixed a rare WIFI bug in the network search
  • Fixed navigation buttons (hopefully this time it is the correct way) after screen rotation
  • Fixed setup wizard (crash on clicking "Next" on different screens)

This may be one of our last big updates before opening the license purchases. All organizational preparations are finished by now and it would be great if we can cover the cost for all the server infrastructure soon. Please don't hesitate to give us feedback on the current developments and on why you are maybe not yet convinced of purchasing. We will be glad to hear which features or bugs you consider the most important - as those are the ones we have to take care of first.

Thank you for your help and support!

Best regards
Igor

«1

Comments

  • edited October 2017

    Hi Igor,
    I tried this latest release, it works flawlessly ... you had done an awesome work :smiley:
    Only bug i found so far is when i rotate the screen to portrait mode the white background underneath the apps is bit big hence it covers the notification and the navigation bars.

    image.png

  • I noticed the portable hotspot is missing from wireless & networks settings ... is there a way to bring it back?

  • Oh, @roxette, sorry... I wasn't aware of those options. Were they working? We did try adding support for wifi Direct in this build, but it broke the normal wifi search. Hmm.... I'll put this on our list. Were they in the settings in our last build?

  • Is there a way of updating without re-flashing the SD card? Can I run an update script via SSH (or adb??) Incidentally, what is the port used for adb? I'm trying to connect via putty and can't connect via SSH or using ADB (from windows) on port 5555

  • @Britkat, updating without re-flashing is definitely something we will add soon. The recovery support was one of the biggest steps there and we are glad it is working now. For now, there is no other way available, but we are working on it.

    The ADB is working on the standard port 5555. The next release will include automatic configuration for the SSH server. Until then you should be able to use adb connect, as mentioned in the setup wizard. Maybe you need to doublecheck your IP.

  • cheers, I did a port scan and 5555 is not open. I'll double check device is still working when I get home. Either way I'll update to 0.3.0 tonight and take it from there

  • edited October 2017

    Hi Igor, yes this option was under wireless & networks settings in the previous release.
    I tried it and yes it works fine.
    You plug an ethernet cable, turn the portable hotspot on.
    This will turn your RPi to a wifi hotspot so you can access it from other devices.
    Therefore the normal wifi will be disabled.

  • @Britkat, try connecting from the same network (not internet), maybe there are some firewall port forwarding rules missing.

  • @kalkov Is there anything I need to turn on locally for adb to be up and running?

  • You mean on the device? It is on by default. Maybe you have turned it off during the setup wizard? In this case you can just enable it in the settings. Just google for "ADB over Ethernet".

  • Hi @roxette. You have really confused me with that AP feature :blush: All the older releases (between 0.1.6 and 0.2.4) crash if I try to enter the extended wifi settings. After taking a look at the source code I really don't understand how it could ever work :smiley: With some small changes I'm now able to enter the settings and activate the AP. However, I don't receive an IP address. Are you sure it was working with emteria.OS in the past or was it just a clever move to trick me into looking into this feature? :wink:

  • edited October 2017

    Scr.jpg

    I'm sorry for the confusion i caused :smile:
    Here is a screenshot from my old phone, as you can see the AndroidAP still saved since the last time i used it.
    Yes, i'm sure it was working otherwise i would complain about it .. right?
    Actually, i do wanted to complain that you removed the bluetooth tethering but i told myself he is pretty busy so leave him alone.
    For the same reason i wouldn't trick you or anything like that :smiley:
    By the way, i just switched to my Linux drive to check which Emteria O.S i was using
    It's v0.2.1 ... hope this helps.

  • Thanks for finding out the version. I do, of course, believe you. It is just that I have no clue how it was possible in the first place :joy: We shouldn't be removing any working functionality in future ;)

    P.S. Wait, what? Bluetooth tethering was also working and it is also gone now? :flushed: :weary:

  • edited October 2017

    @Igor,
    I'm 100% that it was working and i do tested it since i saved that AndroidAP, nevertheless we have 2 possibilities :
    1- I have a magician who fixed it for me :smiley:
    2- I was using RTAndroid
    Was it working under RTAndroid?
    Regarding bluetooth tethering No it wasn't there in the 1st place so i wanted to ask you why did you remove it.

    Bdw: Emteria OS v0.3.0 is the fastest release i ever used however i'm experiencing some random system halts and i have no idea what causes it.

    It's weird that system halts sometimes occurs when i leave the Pi unattended.

  • @roxette said:

    It's weird that system halts sometimes occurs when i leave the Pi unattended.

    the same for me... and the "stripes are always visilble underneath and above the screen if a screen image fully loaded ....the second while loading (processing) the are no strips
    as an example the "wether" app and::

    whats about Bluetooth LE it is supported ?
    I bought extra a new raspberry to get my Healttracker-app to run but it doesnt work

    for others - im doing my downloads over "APKPure" or "Aptitude".. that works fine

    regards Ron

  • I bought extra a new raspberry to get my Healttracker-app to run but it doesnt work

    PS: the pairing doesnt work

  • edited October 2017

    hello at all,

    my problem is solved .. i have changed the powerSupply with an LIPO-Battery buffered selfmade powerbank - now i can connect to my Bluetooth (LE) system and there are no stripes at the screen and the Mousepointer is ok also - tested only with these one App

    thanks Ron

    PS : if somebody made the same experiance i would be glad to hear about
    Note: at first i used the original RPi Powersuppy !

  • edited October 2017

    @RonS, thank you very much for your update. We will check if this is something power-related. Pretty strange though.

    @roxette, we did not remove any specific functionality (except for the telephony stuff) on purpose. If no bluetooth tethering settings are displayed, there are problably some requirements we did not meet yet. BTW: I have invested some time yesterday in researching the AP issue. I know now why it was there previously, but isn't there now (it is somehow related to the telephony service, which we removed a couple of weeks ago). This is very strange, as there are no logical dependencies between them. We will re-add the telephony service in the next release just to make sure nothing else is affected.

    We will try to reproduce those random halts for further investigation. Thank you both for your feedback!

  • So i wasn't dreaming that it was there and was working too :smile:

    I want to disable the onboard bluetooth and connect a USB adapter instead
    It it possible?
    I know in Raspbian you just add the following to config.txt
    dtoverlay=pi3-disable-bt-overlay

  • Well, yes, it was there :) But I can't get it to work... and the version 0.2.1 doesn't work in my network too (I get no IP address). I'll continue looking at it.

    Regarding the bluetooth: I really don't know. Feel free to try it out :)

  • edited October 2017

    Before you turn on the portable hotspot make sure you are able to browse the internet using the LAN cable then it will work.
    The Pi refused to boot after adding the above line to config.txt
    However, in Raspbian adding the following lines to config.txt has disabled wifi and bluetooth
    dtoverlay=pi3-disable-wifi
    dtoverlay=pi3-disable-bt
    Then i connected the USB bluetooth adapter and it worked out of the box :smile:

    I'm sure you can solve that issue, please look at it when you got time :wink:

    2017-10-10--.png

  • edited October 2017

    Update: i figured it out, i think /boot/overlays/pi3-disable-bt.dtbo is corrupt or something!
    Because i overwrite it with the Raspbian file now the Pi boots normally and the onboard bluetooth is disabled, However, my USB bluetooth adapter is not working
    Did you add drivers for USB bluetooth adapters in Emteria OS image?

  • by the way bluetooth .. how can I change the settings .. a data transfer(from a another smartphone ) breaks after a few seconds and a message is visible which points to a bluetooth app ?? but i cant find such an app

    elsewere my system is running since more than 5 hours in this evening , the bluetooth connection to my healthtracker is stable and a screen image witch isnt to big is displayed without any stripes

    im nearly satisfied *LOL
    regards Ron

    note : i still powered my system with my own battery buffered unit

  • The onboard bluetooth is buggy and always crash while using my Logitech bluetooth keyboard.
    That's why i want to disable it and use USB bluetooth adapter instead.
    The app you're referring to is bluetooth share?

  • The app you're referring to is bluetooth share?

    yes..

    bluetooth works with very low levels and a little more ripple frome a power supply can disturb all connections i think so i tested my battery buffered system and it works ..hope it helps
    this part plus a 3600 ma battery I have used
    https://www.fasttech.com/products/1449103

  • This PCB output is 1.6A@5V, the original power supply is 2.5A@5.1V
    Therefore the original power supply will give you much stability than it.

  • Thought I would give a spin.

    Running Rpi3 via hdmi to LCD TV

    How do you enable the virtual keyboard?

  • @Airwolfuk said:
    Thought I would give a spin.

    Running Rpi3 via hdmi to LCD TV

    How do you enable the virtual keyboard?

    figured it out - thanks

  • @roxette, good news: the tethering is working (again?!) :smile:
    It will be included in the next release. Thanks for bringing it up!

  • Hello kalkov,

    what is the password for a ssh connection ?

  • There is no password. It can only handle private keys.

  • edited October 2017

    Wow, that's awesome Igor :smiley:
    I'm so happy coz you were able to figure it out.
    I really appreciate it.

    By the way, is it possible to open a new thread later for drivers request?
    If yes then here is my 1st request

    Device: ID 0db0:1967 Micro Star International Bluetooth Dongle
    Device Descriptor:
    bLength 18
    bDescriptorType 1
    bcdUSB 1.10
    bDeviceClass 224 Wireless
    bDeviceSubClass 1 Radio Frequency
    bDeviceProtocol 1 Bluetooth
    bMaxPacketSize0 64
    idVendor 0x0db0 Micro Star International
    idProduct 0x1967 Bluetooth Dongle
    bcdDevice 5.25
    iManufacturer 0
    iProduct 0
    iSerial 0
    bNumConfigurations 1

  • Sure, feel free to post it where you like. I have not found a dedicated driver for this one, so I included the most prominent ones. It will be in the next release. If your dongle still doesn't work, you may need to check which driver/module is required.

  • edited October 2017

    Thanks Igor,
    This bluetooth dongle works out of the box under windows 10, Linux Ubuntu, Raspbian, OpenELEC and LibreELEC
    So i think it should work with the drivers you included.

  • We have just uploaded a new release 0.3.1.
    Main fixes are:

    • Updated Linux kernel
    • Fixed WIFI tethering
    • Included SSH config
    • Included telephony
  • Hi Igor,
    I'm afraid that onboard bluetooth has stopped working after the included drivers.

    The USB dongle isn't working either.
    Error:
    module_start_up failed to start module" hci_module"

  • Oh, it's never that easy, mh?! I'll take a look at the onboard BT as soon as I get back to the office.

    Does the dongle get recognized by the kernel?

  • edited October 2017

    @roxette, I've just tested it on my private RPi3 at home. The onboard Bluetooth does work for me. Even better: the file transfer is also working now :smiley: I'm pretty sure it wasn't working before. After sending a file from my phone to the RPi, the BT-Share application crashes, but the file is actually transferred. Which is definitely more than we had in the last release :lol:

  • hello kalkov,

    I am frustrated, bluetooth doesnt work anymore , cant switch on this ,
    the file transfer has also worked before and now not anymore
    there must be a big bug in this release

  • hello RonS, as you see I cannot reproduce this behavior on my hardware. We will continue testing.

  • edited October 2017

    @Igor, Are you sure that you flashed v0.3.1 on your own RPi? :smiley:
    Because it doesn't work as RonS wrote.
    The file transfer was working in previous releases but it's useless because it will definitely crash specially if you are sending large files.
    That's why i wished to get rid of that built-in bluetooth.

    @kalkov said:

    Does the dongle get recognized by the kernel?

    When i do lsusb i can see it in the output
    Bus 001 Device 005: ID 0db0:1967

  • edited October 2017

    Here is some other info about the bluetooth dongle from my linux drive

    [ 746.488032] usb 2-1: new full-speed USB device number 3 using uhci_hcd
    [ 746.748083] usb 2-1: New USB device found, idVendor=0db0, idProduct=1967
    [ 746.748088] usb 2-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0

    Manufacturer: Cambridge Silicon Radio (10)

  • After thinking a bit, I might have found the bug. It seems the uart handling was changed in the new kernel (https://github.com/anholt/linux/commit/f08f58a2bf68900a84e782b8c7ad701c0654173c). Yes, I'm sure I was using 0.3.1 (for several days now), but my debugging console is set to serial0, instead of serial1 (which is used in the release). Its possible that changing this line in boot/config.txt would help. I'll check it tomorrow. Or maybe somebody else will be faster than me.

  • edited October 2017

    enable_uart=0
    unable to open file '/data/misc/bluedroid/bt_config.bak' : no such file or directory
    startup_timer_expired
    module_start_up failed to start module" hci_module"

  • edited October 2017

    I want to mention that wifi tethering is working pretty nice ... thanks Igor :smile:
    If you guys got a long range USB adapter then you can disable the onboard wifi and get a powerful wifi hotspot :wink:

  • I've just uploaded a new version with fixed bluetooth.

  • edited October 2017

    Oh, yeah onboard bluetooth works again :smile:
    I want to comment about my USB bluetooth dongle as it's not working.

    • It's recognized as a USB audo device.
    • It has different vendor and product id.
      What's wrong? :smile:

    Edit : lsusb shows the correct ids 0db0:1967

    Perhaps it's not working the same way like Raspbian?
    Because i had to disable the onboard bluetooth in config.txt first.

    image.png

  • edited October 2017

    putty.jpg

    putty_phone.jpg

    Hi Igor,
    I can't connect via SSH :port 5555 using Putty on Win10 as well, however i downloaded some SSH server app off Google play and it works fine.
    As you can see in the attached screenshots
    1- Putty on Win10
    2- Putty on phone although i don't understand what does this error mean
    can't find tty fd: No such device or address
    Any idea?

  • putty_phone1.jpg

    Update:
    I used another SSH server app which doesn't reproduce the error, it also connect on port 22.

  • linux.png

    My bad!! it works under Linux Ubuntu :smiley:

Sign In or Register to comment.