Adding Google Play Store

Hey all,

I understand that emteria OS does not have a recovery feature, and therefore our options are only running the RTandroid script. Is the process the same? There seems to be a lot of conflicting information regarding this topic. Just trying to get the play store up and running on my rpi3 with emteria.os and official pi screen (element 14). Any help would be appreciated. Downloading a Linux distro to attempt running the script now.

New user,
Thanks

Comments

  • Has anyone successfully put the play store on rpi running Emteria.OS? I know you have to run the script on a linux distro in ADB connect (I believe).

    Are there any tutorials or walkthroughs for this yet?

  • Hey,

    we're working on adding a recovery system for the Raspberry Pi. Once this has landed, it will be much easier to install for example OpenGApps.

  • Any idea on when the recovery system will be added? Are we talking days, weeks, months?
    -rough ETA could be helpful, I know it's not easy to determine

    I'm in the middle of a project and could use some guidance from those who have emteria OS and have managed to add the play store through the RTandroid script.

    Thanks in advance

  • I was able to run the gapps.sh script from the old rtandroid files. I believe I only had to make two changes. The real problem was finding the correct URL for the gapps package. I used a browser to determine the new URL and then substituted in the script as below. The URL for the current gapps version may have changed already? The commented # line being the old and the other line the replacement. TIMESTAMP is near the top of the script. wget is in the prepare_gapps section. I also cleared the gapps directory before running. As it took me a few tries to get this right, there's not guarantee this was the final way that worked - but I'm pretty sure it is. If not, this should get you started.

    TIMESTAMP="20170901"

    TIMESTAMP="20170207"

    wget https://github.com/opengapps/$ARCHITECTURE/releases/download/$TIMESTAMP/$PACKAGE_NAME -O gapps/$PACKAGE_NAME

    wget https://github.com/opengapps/arm64/releases/download/20170901/open_gapps-arm64-7.1-pico-20170901.zip -O gapps/$PACKAGE_NAME
    
  • Well, the editor didn't like what I wrote above and made some changes on me. I should've previewed. the wget line with the url completely spelled out (not substituted) is the one that worked for the then current version.

  • Hey,

    recovery support will be at most 2 weeks out.

  • Hi,
    No need to insert the gapps url,
    Just change TIMESTAMP to the latest version.
    For ex.
    TIMESTAMP="20170913"

  • Tried changing just the time stamp initially and it didn't work for me. If that works for whomever, great. If not, try searching for and replacing the new url in the wget statement.

  • I just changed the time stamp and i installed gapps 20170914 successfully.
    I don't know why it didn't work for you as it's meant to be working without replacing any url because the file will be fetched and downloaded according to the time stamp you specify.

  • Thanks for the help guys. Managed to get the play store up and running!

    Finally got my usb GPS to work, and Android Auto and Waze are getting the gps signal, but the Waze map stays black and Android Auto is laggy at best. I read somewhere that it could be due to hardware acceleration options needing to be changed but I haven't dug into it too deeply, and the settings available didn't seem to change anything.

    If anyone is running Waze or AA on rpi3 (emteria.OS) please let me know what you did to get it working.

    Thanks in advance

  • I remember i also installed Waze and uninstalled it for the same reason.
    Go to Settings - Developer options then turn on force GPU rendering
    Let me know if it works or the map remains black.
    You can try Sygic instead, it works pretty fine.

  • @PhoeNix I am pretty new to the pi3 and would like to have the play store to install apps. Kodi would be my first install.

    Could you please provide a step by step tutorial about how to install the play store after installing emteria with the official installer here?

  • @ZΞC the easiest way to download the play store at the moment (in my opinion) is to:

    • Go to settings > security > enable "unknown sources"
    • Go to the browser and search for "Flashfire APK" and download the file and install.
    • Go to broswer and search for "GApps Android zip file" and download the package you want (there are different packages with more or less GApps, if you just need play store, get the Pico or micro package)
      -Open flashfire and select the Gapps zip file you just downloaded and follow the instructions to flash your SD card. Your Rpi3 will reboot and you should have the play store.

    Hope that helps!

    Enjoy

  • edited September 2017

    @PhoeNix , i replied to your question but i see no feedback from your side.
    Did Waze work or you still see a black screen?

  • @roxette I said that I already tried changing the settings available and it did not work. I had already tried the force GPU rendering with no luck. Thanks for the follow up though. Still working on it.

  • edited September 2017

    Hi, I installed google play on raspberri PI 3.
    Here are instructions, how install:

    1, Download rtandroid-aosp-7.1-20170404 from page: rtandroid.embedded.rwth-aachen.de/downloads/raspberry-pi/

    2, Open and edit file gapps.sh -> TIMESTAMP="20170207" change to TIMESTAMP="20170901"

    3, Run adb
    4, Conncet: adb connect (ip-address of raspberry)
    5, Run script: ./gapps.sh -a arm (ip-address of raspberry) -i
    6, Waiting to end of running scrip
    7, Reboot

    Works for me.

  • Just to put here an update: with the latest release, you could install OpenGApps via recovery. Just like on any other mobile device.

  • Hi i am trying to get de gapps.sh script for googleplay but rtandroid download not available anymore any issue ?

  • Hi! I install opengapps on recovery, wipe davlik and boot, but startup wizard crashing and cant continue

  • Why do you wipe boot? I don't wipe anything and it works fine.

  • By now I tried it twice to install the GAPPs zip. As it was ready I couldn´t start the GooglePlayStore or another Google App. The Apps were always closed with no reason. Did I have something wrong? I need the PlayStore to connect my RPi with a Googleaccount to buy an App.
    Can someone help me please...

    Thanks by now.

    P.S.: In the next days I will try PhoeNix solution

  • edited November 2017

    Just a little feedback: I got it work with the installation of the root FlashFire APP. Now it is working!

  • Hello. Which version of gapps did you use? arm or arm64?
    I tried the 32-bit version with flaschfire. Unfortunately, the pi then crashes when setting up. I can choose the language, but then it is over. The setup wizard will be restarted.
    Can someone hlp me please?
    Thanks

  • Hi Gersch,
    sorry for the late answer. I choosed the arm version Android7.1 and the pico.
    Greetings
    David

  • Hello, you need the latest apk, download here https://www.playstoredownload.blog and go to download page.

  • I found an easy alternative. If you enable all of the choices for app sources on the built-in app store, you can download "Yalp store" (the google play symbol backwards and all blue). It allows you to download APKS from the play store and will auto update them when needed (I was able to download stuff that was not in the built-in app store like rules of survival and Blue Mail)

Sign In or Register to comment.