Emteria + New Raspberry Pi 3 B+


I've tried to run Emteria on the new Raspberry Pi 3 B+, but it won't boot. I cannot see any splash screen or what ever.
Is there a known issues and will be it fixed in the future?



  • Hi,

    can we expect any release the next days for the Raspberry Pi 3 B+?


  • There might be a new release in the next few days, but you can pretty much test it yourself by copying the device tree blob for the 3B+ from here:


    To the boot partition.

  • Thank you for the answer. I've tried to use the firmware which you linked, but the screen hangs in the "rainbow" boot phase. Afterwards I've copied other files from https://github.com/raspberrypi/firmware/raw/master/boot/ and replaced these in BOOT. Still now working and it hangs in Kernel/Service boot. The Emteria boot screen splash will not shown.


  • I have to mention that I am using the official Raspberry 7" touchscreen.

  • That's probably a bad failsafe choice - do you have a HDMI display by any chance?

    In any case, if adding the device tree didn't help I'm afraid a new release won't either. It will be some time before we have a 3B+ revision and some time to test. If it doesn't work with HDMI, the only remaining step is to connect a serial debug console.

  • It seems the problem is the older kernel version Emteria is using.

  • Is there a solution for this issue? I tried the same configuration RPI3 B+ HDMI and with Touchscreen and ran into the rainbow boot loop. It does not boot.

  • No, two screens at the same time are not supported for now.

Sign In or Register to comment.