Cant Update to 0.5.13/.14

i tried letting it download over Wifi and over ethernet, and it fails to verify zip signature. anyone else having a problem?
Edit: checked teh file size so im not sure how big the update Should be but it downloaded a 343.07MB Zip.
edit 6:20PM: tried again still fails on zip signature, but now is downloading 0.5.14


  • same here, i'm on 0.5.13, faild to verify zip file 0.5.14, tried multiple times to redownload

  • Hello,

    I am facing problems with the update too. I am running Emteria on a Raspberry Pi 3. The device is connected via WLAN to my router. The installed Emteria Version is registered.

    When I am trying to update to the update fails. The progress bar fills the complete screen but the the message appears that the download failed and that no file could be found.

    Starting the update manually from the settings menu does not fix the problem.

    What can I do?

    Thank you!

    Kind regards


  • Thanks for reporting, I'll check it today.

  • edited May 2018


    I got it working. First problem was the internet connection via WLAN. It caused a download problem. Why? I do not know. The signal strength was optimal, all other internet applications work fine, including downloads. I connected the Pi3B to a LAN cable and now the download completed.

    Then the device rebooted after klicking install. Then it said "skipping digest check, no digest file found". After that "verifying ZIP file" and then the error message "ZIP verification failed" and "error installing zip file".

    So I got to the boot manger menu and pressed install, selected the zip file /data/... , unchecked "Verification of the ZIP file" and the flashed version 0.5.14. After that I did a reboot and the system was busy for approx. half an hour.

    Now it works again.

    Kind regards


  • Thanks. We couldn't reproduce this error in our lab, so I think it was because of your wifi connection.

  • Thats strange as all other internet downloads work great.

    One question: why could the not be verified?

    Thank you and best regards!


  • It is a bug in our deployment scripts. I hope we will find some time to fix it soon.

  • Hi,

    I tried to update to 0.5.14:

    • the download is ok
    • after I click "install" it goes into recovery and it says "verifying zip signature..." and after 10-20 secondes it goes directly into the recovery main menu (with the buttons install, wipe, backup, restore, etc.)
    • I reboot and I'm still in 0.5.10 version.

    I tried several times today.
    I have an activated version ofcourse.

  • after trying one more time, I saw a red message for 0,5 sec before going to recovery main menu.
    I didn't have the time to read it, so I tried once again but this time I used my phone to film it and see on the paused video what the red message was:

    Verifying signature zip...
    zip signature verification failed!
    error installing zip file '/data/ota_package/v0.5.14/'

    Done processing script file

    so the failed signature is the cause of update not installing

  • As a workaround (for those who have the same issue):

    • copy the zip file from /data/ota_package/v0.5.14/ to downloads
    • reboot in recovery
    • manually launch the install and uncheck the box for "verify zip signature"
  • @Andybv said:
    As a workaround (for those who have the same issue):

    • copy the zip file from /data/ota_package/v0.5.14/ to downloads
    • reboot in recovery
    • manually launch the install and uncheck the box for "verify zip signature"

    Its not really necessary to copy the file to downloads. You can choose install, then choose the folder which contains the ota zip file and then install it - but be sure to uncheck "verify zip signature". :)

  • Updated to 0.5.16 yesterday evening. Still problems loading the File via WLAN, but the install procedure worked good.

Sign In or Register to comment.