WiFi Disabled/Stuck at "Turning WiFi On"

Hey Emteria,

I'm having an issue now with my WiFi showing as being Disabled and when I go to the WiFi connections page, it shows "Turning WiFi On". The same goes with Bluetooth, however, I just played with some settings and the Bluetooth went from being "Disabled" to "Disconnected" so I don't think it's a hardware issue. The WiFi was working fine until last night. I went ahead and installed the RPi into my car and after a few minutes of messing around, the WiFi turned off. I went to the settings to turn it back on, but, it started showing "WiFi is Turning On". I tried formatting the SD Card to a fresh install of Emteria.OS, but unfortunately, the WiFi is still doing the same thing. Does anyone have any ideas or have experienced this same issue?

All help will be appreciated,


  • It also seems as if the Bluetooth is turning itself off, showing "Disabled", and then turning itself back on.

  • Sorry to hear that. To be honest, I haven't heard of similar problems with WiFi so far. Do you have a possibility to connect an Ethernet cable and retry enabling WiFi? In case it fails, please submit a bugreport (Settings -> Emteria -> Bugreport) and I'll check the logs.

    The Bluetooth is known to be quite unstable so far (at least with BLE applications).

  • I have the same problem. Came after 6 hours or something like that, before that it worked flawless. The programs i installed are: Kodi, Spotify, & wifi prioritizer. ( I've tried a clean install but the problem stays. ) Tried also to install Raspbian but than i had wifi. ( so it looks like that my wifi adapter is not the issue ). I use the stock raspberry wifi card btw.

  • What is "stock raspberry wifi card"? RPi has a built-in Wifi, no additional cards are required.

  • BTW: there is another discussion with the same topic, so lets move there: https://forum.emteria.com/discussion/403/wifi-disabled-stuck-at-turning-wifi-on#latest

This discussion has been closed.