Cannot boot emteria v0.5.20, due to resolution not supported by television.

To my surprise the new version of emteria os v0.5.20, is no longer able to boot on my television due to the resolution that is not supported. Note that up to version v0.5.16, resolution was supported correctly.
I tried to check the config file inside the boot partition and changed it to a 720p resolution, unfortunately to my surprise the resolution is first moved to 1024x768 and then back out of scale again.
I'm afraid that the resolution is completely out of control by the config file.
How do I restore the old configuration to version v0.5.16?
Tomorrow I will do more tests in my office with a real monitor to see what resolution you use.


  • Thank you very much for reporting this problem. We have re-implemented the resolution detection for giving users the possibility to set their own resolution in emteria settings.

    We never had the possibility to control the resolution by modifying the config file only, as Android requires at least one additional change in /system/build.prop.

    • Which resolution was set in the config file once you have opened it?
    • Was emteria.OS able to boot at least once after setting the resolution to 720p?
  • Good morning
    This is what was written to the file at the time of the first boot:

    hdmi_cvt=1280 720 60 6 0 0 0

    I just changed the string:
    hdmi_cvt=1280 720 60 6 0 0 0

    With this:
    hdmi_cvt=720 480 60 6 0 0 0

    From here the system starts and I can see the initial loading part with the writing, then later it increases the resolution 2 times and it goes back to 1280x720 (that is the resolution not supported by my television).
    From here on I can't do anything anymore because I can't see anything anymore.
    I tested with a real monitor that does all the resolutions and works, so from the monitor I can move the resolution.
    This is causing me great inconvenience, I would not want to have to take my raspiberry to the office every time I make a change to the operating system.

  • A proper solution would be finding out what resolution is supported by your TV, configuring it in the emteria settings and disabling automatic detection. If you are sure that 720x480 works, navigate to Settings -> Emteria and enter set it as preferred resolution.

  • I've verified...
    As you can see from the photo the Android resolution varies and is proportionate as I requested, but in reality it always remains at 1280x768.
    Obviously my television still doesn't display anything, except in the boot where the resolution I configured in the config file is placed.
    To be more precise about the problem, do you want to make a video?

  • Yeah, it might be helpful to see a video or to get more details. To be honest, I didn't understand it completely.

    As I've said in my last message, you can set the desired resolution from the settings (I think it is in RPi-specific settings). Just set whatever you wish and disable automatic detection (automatic mode settings) below.

  • OK... I prepare the video and send it.

  • Also installed emteria.os android on my Rasp but a "not supported resolution" was displayed. POST and BOOT first screen was shown but then resolution error came.
    Can I solve it via PC monitor?
    Please send any step by step method.
  • neither 1024x600 config worked for my TV as suggested on

    Enforcing custom resolution using “fkms” overlay

    Enforcing custom resolution by manual configuration

    found at:
    My Rasp runs RetroPie at 1360 x 720 but not even that resolution worked

  • Does it work with a PC monitor? In that case you should use a fresh installation, navigate to Settings -> Raspberry Pi -> Resolution and try setting it manually.

Sign In or Register to comment.