Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Building an Android TV Box - No success cause of ROOT

Hello,
i'm currently struggling with EmteriaOS on Raspberry Pi 3b+ because the system is rooted by default.
I wanted to install Sky Go, Netflix and other apps but most of them don't work with a system that is basically unrootable.

I tried apps like "Hide my Root", "RootCloak" and others - no success.
I tried using the app "SuperSU" and unroot completely - no success.
I tried to deactivate and delete the "Superuser" app installed by default - no success.
I tried to change the root permissions in the developer's settings - can't be found.
I even searched for the "su" file in /system/bin and /system/xbin - not there.

Is there ANY way to unroot this system? There are many users who aren't really into rooting their devices for reasons like the one above, so at least being able to choose what to do with their systems would be appreciated.

Comments

  • i would cancel my suscription to "sky" or else if i had one when they didn't allow me playing on an a rooted devices, but netherless, i have TV-Boxes which have already root access and they are running most of these apps ?????

    @RyoPi, Raspberry Pi is not the best choose for a TV Box

  • @DrRokko What separates the Raspberry Pi from those chinese TV Boxes you find online is that it can be shaped in whatever you want and its purpose can be changed with just a SD card swap, so it's pretty much a no brainer when it comes to choose between that and a closed system that only does one thing.

    The Raspberry Pi can be a pretty good TV box with other apps like XBMC and LibreELEC, but those are a bit more complicated for "regular people" with their way of work and their not fully intuitive GUIs.

    With Emteria instead, the Raspberry Pi can become a good TV box that's also easy to use. The problem is that it doesn't give you the chance to unroot or hide the root to use legit apps just like (some) other Android TV Boxes. It's pretty much the only thing that keeps Emteria from being a good Android TV system.

    Should we cancel our subscriptions to Sky, Netflix and other on demand services because they have to protect the contents they put on? No of course, that's just being silly.

    I just thought Emteria worked like most Android systems out there, so i would like to know if there's really no way of unrooting it.

  • Well, emteria does work like most others Android systems, but I have not enough knowledge about what exactly those applications check to provide specific steps for unrooting. Everything you said above (deleting Superuser app from /system and deleting /system/xbin/su binary) should be doable. I don't know how system will behave without them though. What exactly didn't work while removing those two?

    BTW: we had similar discussions in the past:
    * https://forum.emteria.com/discussion/comment/912/#Comment_912
    * https://forum.emteria.com/discussion/277/unroot-emteria/p1

  • @kalkov Yes i found those discussions too, but the /system folder is just empty, so something changed in this version of the system.

  • I’m having the exact same problem. My guess would be Sky are using the Google Safetynet API, so advice on how to return the device to be able to pass the standard tests (excluding known device) would be a good start.
  • The /system partition cannot be empty. Otherwise the device won't boot.
  • From my findings (with es explorer):

    1) There is a root folder in /root. You can delete it but it is recreated again when you go back
    2) There is no su app in /system/
    3) There is a /system/xbin/su file but cant be deleted

    So i have not high hopes if you can unroot this thing. Too pitty cause it looks really promising :'(

  • @Haris1977, the "root" folder doesn't mean that the device is rooted. I don't believe it has influence on this decision. You can actually delete /system/xbin/su if you wish. Please google "adb root", "adb remount" and "adb shell" and use the ADB over Ethernet feature from emteria settings.

  • If (i say if) Emteria can be fully unrooted why dont you share with us how to do it?

  • Because my time is limited and I can't write detailed tutorials for each single request. Google it, and you will be able to do it yourself. You could also purchase extended support and we will be happy to help you.

  • BTW: Netflix works just fine: https://streamable.com/ztqrz

  • edited December 7

    Anything can be deleted on the sdcard even while running...

    If you enable ssh following the FAQ on it here then you can use

    mount -o remount,rw /system

    delete /system/xbin/su and the Superuser app from /system/app/

    then reboot

    Before you want to play admin you must first RTM.

    And finally should there be a OTA all this will most likely have to done again. Of course if you break the system it's not my fault.

Sign In or Register to comment.