SSH connection refused

edited March 24 in General

Hi Kalkov,

I'm a little bit confused of key sharing with adb and connecting with ssh. Followed the steps on kb how to set up ssh but my connection will be always refused, see below?

C:\Downloads\platform-tools_r28.0.2-windows\platform-tools>adb pull /data/ssh/ssh_host_rsa_key my_private_key
/data/ssh/ssh_host_rsa_key: 1 file pulled. 0.2 MB/s (1675 bytes in 0.007s)

C:\Downloads\platform-tools_r28.0.2-windows\platform-tools>adb pull/data/ssh/ssh_host_rsa_key.pub my_public_key.pub
adb.exe: unknown command pull/data/ssh/ssh_host_rsa_key.pub

C:\Downloads\platform-tools_r28.0.2-windows\platform-tools>adb pull /data/ssh/ssh_host_rsa_key.pub my_public_key.pub
/data/ssh/ssh_host_rsa_key.pub: 1 file pulled. 0.1 MB/s (398 bytes in 0.007s)

C:\Downloads\platform-tools_r28.0.2-windows\platform-tools>adb push my_public_key.pub /data/ssh/authorized_keys
my_public_key.pub: 1 file pushed. 0.0 MB/s (398 bytes in 0.009s)

C:\Downloads\platform-tools_r28.0.2-windows\platform-tools>adb ls /data/ssh
000081b6 0000018e 5c95f8f0 authorized_keys
000041f9 00001000 5c4b251a ..
00008180 00000d08 5c4b25af sshd_config
00008180 0000029c 5c4b25b1 ssh_host_dsa_key
00008180 0000068b 5c4b25b6 ssh_host_rsa_key
00004180 00001000 00000002 empty
000041f8 00001000 5c95f924 .
00008180 0000025e 5c4b25b1 ssh_host_dsa_key.pub
00008180 0000018e 5c4b25b6 ssh_host_rsa_key.pub

C:\Downloads\platform-tools_r28.0.2-windows\platform-tools>adb ls /data/ssh/authorized_keys

C:\Downloads\platform-tools_r28.0.2-windows\platform-tools>ssh
usage: ssh [-46AaCfGgKkMNnqsTtVvXxYy] [-B bind_interface]
[-b bind_address] [-c cipher_spec] [-D [bind_address:]port]
[-E log_file] [-e escape_char] [-F configfile] [-I pkcs11]
[-i identity_file] [-J [user@]host[:port]] [-L address]
[-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
[-Q query_option] [-R address] [-S ctl_path] [-W host:port]
[-w local_tun[:remote_tun]] destination [command]

C:\Downloads\platform-tools_r28.0.2-windows\platform-tools>ssh -i my_private_key root@192.168.157.33
ssh: connect to host 192.168.157.33 port 22: Connection refused

C:\Downloads\platform-tools_r28.0.2-windows\platform-tools>

could you please give me a hint or advice?

Tagged:

Comments

  • Is SSH activated in Settings -> Emteria?

  • Yes, I also did restart the pi to be shure its active.

  • is there an option on the pi (in the emteria.OS) to proof the ssh server is running proberly?

  • So, after i tried with another sd card and the original one with fresh installation, it worked with putty and both of them.

    Wich leads me to the conclusion, that something of the first installation was broken.

    Think the thread can be closed.

This discussion has been closed.