Odroid USB GPS not working on Raspberry Pi 3 B+

edited July 26 in General

Dear Community,
I got a Raspberry Pi 3 B+ and installed Emteria OS on it. So far so good.
In the Emteria knowledge base for the Raspberry Pi 3 B under the GPS point it says: 'Built-in support for ODROID’s USB GPS Module without additional configuration.'
I had a ublox GPS module but it didnt work so i bought another ublox GPS module labeled odroid and it still wont work (both are ublox-6010 chips).
I'm aware of some workarounds but since i got not that much experience in adb and such stuff i would like to interpret the above mentioned that i dont have to do such kind of 'additional configuration'

So, is it possible to get an USB GPS Module to work by just plugin it in? If so, what am i doing wrong?
If there is any other easy way to get the module to work, please share.

Thanks and all the best.

Tagged:

Comments

  • Did you enable Location in the settings?

  • Yes, it is enabled :)

  • Can you please describe how you are testing it?

  • Sure.
    I plugin the USB-GPS-Module, start up the Raspberry Pi, see if the GPS in enabled and then start a navigation program. The GPS icon shows up but no location is transmitted.
    Yesterday I tried another way. I installed a GPS app which gave me the option to select my GPS-Device (it listed the ublox chip), i selected it and enabled the app, then instead of the GPS/location-icon a satellite icon appeared and inside the app it showed me long and lat. I tested it and it was right. I left the app open and opened a navigation app and taaadaa it showed my correct location in the app.
    I accepted that the gps data goes through that app. With that and the app running in the background it worked.

    I'm currently at work, so i cant provide u with any pictures or the name of the gps app i was using. I can add this information later this day.

    So it seems that the OS doesnt know how to use/access the USB-GPS-Module but through the app i can select it. Funny is that the app shows a satellite icon where the OS/navigationapp shows the location icon.

    If there is anything else you would like to know to get a better picture of the situation, feel free to ask. And as i said, i'll provide u later this day with more details.

  • Could you tell me name of the GPS app which you were talking about? And second question: If you connect GPS receiver to the USB and reboot (for sureness) which tty* devices do you see in the /dev direcotory? Is there ttyAMA0 or ttyAMA1? You can use e.g. total commander.

  • The app is called UsbGps4Droid
    And the device is listed as ttyAMA0

    thanks a lot for the support so far :)

  • edited July 17

    Emteria should work with the GPS device ttyAMA0 by default. @kalkov please could you send me the original Emteria gps.c file without my modifications. Current version of GPS driver is derived from the Keith Conger's code and it is possible that your original version contains some initialization for Odroid receivers which were lost by my modifications.

    I checked this one: https://osdn.net/projects/android-x86/scm/git/hardware-gps/blobs/oreo-x86/gps.c If it's Emteria original version which worked with Odroid GPS then current version should work too. I didn't find any important differences there.

  • @Martin, I will create a public repository on GitHub with our GPS source code and let you know.

  • https://github.com/emteria/external_gps
    I see no functional changes in comparison to Keith's code.

  • @Martin, I can add you as a project member, if you wish. But it looks like you have two different GitHub accounts.

  • Hi @kalkov, please use that one with the Gmail address.

  • I can't see your email address. I just guessed... did you receive an invitation?

  • Hi, I have created this pull request https://github.com/emteria/hardware_generic_gps/pull/1. Measure rate management is only one significant change in the current GPS driver, so I have changed its activation so that it would be only on demand.

  • Awesome, I'll test and merge. Thanks!

Sign In or Register to comment.