Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Ethernet Connection not seen in Android ui / Adding static routes, which works well

Hello,

I would like to configure manually IP settings for my RPI3/Emteria.OS, because i want this Rpi3 to have a specific gateway, different from other machines (a transparent proxy server). currently RPI3 is connected with ethernet/dhcp
I can't see Ethernet interface in Android UI, only Wifi and Bluetooth are present (and VPN, etc in "more"), is it possible t have ethernet options ?

In a different way to reach my proxy, i also tried putting a new static route for this proxy. Route added : OK (seen in route -n) but seems not activated, i mean "ip route get" doesn't give the right specific gateway, only the default.

Where are my mistakes ?

Thanks
Benoit

Comments

  • Android doesn't provide any settings for static IP by default. You can try setting it up manually (not tested):

    # ip link set eth0 up
    # ip addr add 192.168.1.10/24 dev eth0
    # ip route add default via 192.168.1.1 dev eth0 table legacy_network
    # ndc resolver setnetdns eth0 . 8.8.8.8 8.8.4.4

    More information on DNS resolving here: https://github.com/ukanth/afwall/wiki/DNS#android-600_r1

  • Hi there,
    i tried the command however the command below did not work

    ip route add default via 192.168.1.1 dev eth0 table legacy_network

    it show the error

    RTNETLINK answers: Network is unreachable

    Also is there any way to save the configuration, every time after the Pi reboot, all the configuration for the Eth0 gone

  • Today we have started with the implementation of a proper settings UI for this. I hope you don't have to wait too long anymore ;)

  • Is there any news yet regarding this feature?

  • Beta support was merged today. It will be in the next release.

  • Could I just ask for confirmation, without this feature, P2P cabled Ethernet is not going work is it?

  • @RS1962, not sure about P2P. But you can install v0.6.0 and try it out.

  • @kalkov, I've now installed v0.6.0 but found a slight problem with the ethernet config settings. It kept crashing when I tried to switch to static IP. It wasn't cabled when I did this so I tried with ethernet cable plugged in and it worked. Surely it should be able to make these settings regardless of a cable being present during config (obviously I'd need a cable at some point later!)

  • @RS1962, thank you very much for reporting. Our current implementation can't work without a cable, since we are using the current (DHCP) configuration for the initial setup of static values. We will come up with a better approach in future, but for now we will probably just limit access to this option to cases when a cable is present.

  • I've also now proceeded to the P2P test and had no issues, all works well. Good work!

Sign In or Register to comment.