App execution failed

Hi, Im a software developer who is using Emteria for Raspberry pi3+ the exact version is Emteria 0.7.1, Im using this version because was the only one working with the oficial raspberry 7inch touchscreen, the problem is.. that the aplication that I want to deploy closes inmediatly after start, When I Debug with my IDE (RAD Studio) this shows an error Cannot activate shader program for TContextAndroid and closes, as I know this is a S.O. error because I tried with my cellphone and can execute the app correctly, even a simple hello word can't be runned by this S.O. because I get the same error, some Idea of what could be?!

Comments

  • Hi, fellow Delphi developer here. We ran into the same issue, although it was just a constant stream of errors in the system log, not an issue that actually caused the application to crash.
    The problem has to with Emteria only supporting OpenGL ES2.0, whereas Firemonkey is built around newer versions.
    We "fixed" it by suppressing these errors. You can do this by modifying FMX.Context.GLEs.pas. In the "GLGetErrorFlags"-function, change "if Flag <> GL_NO_ERROR then" into "if (Flag <> GL_NO_ERROR) and (Flag <> GL_INVALID_VALUE) then".

Sign In or Register to comment.