Setting Default Sound Device

I have added a USB sound card to my rpi Emteria system. It works fine, but it is now the default sound device for everything in Emteria.
How can I set the default sound device Emteria uses to something else ? Or even switch sound devices on the fly?

Comments

  • Commandline? Unsure what Linux command would do that?

  • Yup from the command line would be fine so the equivalent of something like:

    pacmd "set-default-sink "

    Which is (I think) how you change this in ALSA in a desktop distro, but Android has a much lighter userspace ALSA.

  • For some context, I can play out of a USB sound card with aplay easily enough, for the application I have in mind. But as soon as I plug in the USB sound card it becomes the default sound device, how can I make the built-in Rpi audio out jack the default again?

  • edited February 20

    @simpz said:
    Yup from the command line would be fine so the equivalent of something like:

    pacmd "set-default-sink "

    How can I access the Command line locally?

  • Enable the local terminal in the developer settings or connect with ADB and type "adb shell".

  • edited February 20

    Thanks, I got the terminal working, just had some difficulty finding the setting.

    However the pacmd command does not seem to be recognized by the terminal.
    I have tried every audio interface I can think of and nothing...
    What interface does emteria use?

  • sudo infront of the command?

  • sudo is not recognized either, I believe "su" is used instead.

    Even with that, all I get is: " sh: pacmd: not found"

  • UPDATE:
    I now realize that Emteria uses TinyALSA for audio control.
    "tinymix" is the installed audio mixer/config tool

    After some editing of the audio_policy_configuration.xml file,
    I was able to restructure the default audio input and output.

Sign In or Register to comment.