Generic TouchScreen Simple and Multi Tap


I have juste bought a generic resistive touch screen on eBay (it seems to be a eGalaxTouch VID_0EEF&PID_0001). It worked out of the box.
My problem is, during the initial setup, i need to hit many time the next button (maybe 3 or 4 times) to go forward. But when I needed to check the checkbox from the user agreement, only one hit is needed.

Does anyone have any idea ?

ps: sorry for my English


  • Are you sure it is really the screen which isn't working? During the very first boot the system performs the initial environment setup and may be somewhat unresponsive sometimes. It may happen that the touchscreen is working properly, but the touch events are ignored by the OS.

  • I think that the touch screen is working properly because I have tried it on Windows with no problem. And When I hit "next" in the setup, I can see a small animation of the button, but I have to hit it a few time more to pass to the next step.

  • Yeah, thats the initial system load. Don't know how that can be fixed... maybe by letting the user wait for a longer time before sending him to the first page of the setup wizard.

Sign In or Register to comment.