Missing powerButton and other stuff on RPi4

I urgently needed an Android device it seemed like a good idea to install Emteria on a RPi3B+ but I had major stability problems with network so I upgraded to RPi4B. Network is perfect but lots of features is missing:
1. Unable to find powerbutton
2. The menubutton on right side of screen is missing (and also the menu itself)
3. Unable to find the enable VNC server menu item

I managed to install the HSTouch app using F-Droid so my RPi4 is doing its major task but still quite annoying with the other missing features.

I noted today that the RPi4 version is just a few days old but this seems to be major features missing. Anything I can do to enable the missing items?


  • Hey @SveinHa,

    The RPi4 Release is a first version and we are still working on it.

    1. Do you mean our PowerOff app? This should be included.
    2. The menu is accessible by swiping up.
    3. VNC is currently not included into our build but we are working on it.
  • Thanks.

    Found the menu by swiping up, and in the menu, I also found the powerbutton.

    I was a bit puzzled by the "disappeared" menu since it is accessible on screen in the RPI3 version.

    VNC is no big deal for me but look forward to see it enabled.

  • Hi @SveinHa ,
    Since v11.2.21 VNC is added to the RPi4 image. Feel free to try it out and give feedback :)

  • Have reflashed and running ver 11.3.0, set VNC password and enabled VNC. Still unable to connect using RealVNC (Which I use for all my other Linux, Raspbian and Windows machines). When trying to connect, I immediatly get this message: "The connection was refused by the computer". Any ideas what to do next?
  • @SveinHa When enabling the VNC, does the option update an show an IP with Port? Have you tried different VNC clients, like VNC Viewer? Just to narrow down the possible issue.
  • It shows 172.16.x.xxx:5901. Tried to manually enter port after IP in VNC Viewer (or VNC Connect as it is called now) and then it fired up just as normal. Have been using VNC for a couple of decades and, as far as I remember, this is the first time I have had to manually enter portnumber when using default port.
  • Default port for VNC is 5900, not 5901. However, on some Android devices 5900 may already be busy by other system services, so we had to switch to 5901.
Sign In or Register to comment.