RPi 4 (emteria.OS v11.2.0) - USB-RS232 driver problem


We test sending USB-RS232 commands using Aten UC 232A. And we came across a problem where RPi4 does not register Aten USB-RS232 as ttyUSB0, but as xhci_hcd. On RPi3 (emteriaOS 1.3.0) everything works properly, Aten registers as ttyUSB0 (pl2303) and commands can be sent to it.

We want to ask why the RPi4 USB-RS232 converter registers badly and not like ttyUSB0?


F. Slezák


  • Hi,

    I would like to remind my question about RS232 on rpi4.

  • Hey @kiwi,
    sorry for the late reply.
    A lot of things changed from RPi3 to RPi4 eg. USB drivers. xhci_hcd is the USB3 driver.
    RPi4 has 2xUSB 3 and 2xUSB 2 ports have you tried a different port?
    Another option to try would be adding dtoverlay=dwc2,dr_mode=host to your config.txt to change the USB driver.
    Another question from my side would be why are you using a USB to RS232 converter isn't the built-in UART on PIN14&15 sufficient for your use case?


  • Hi,
    thanks for the reply, the ports we tried and the behavior is the same.

    Where exactly should config.txt be located? In the /boot folder?



  • Hi,
    so i found it in the /boot folder, but it's set up correctly. Can you think of another solution?

  • @kiwi
    The dtoverlay=dwc2,dr_mode=host you have in the config.txt is only applied when running on a compute module (cm4). If you are running a normal RPi4 you need to put it under the [all] guard.
    Meaning: try to copy line 3 to somewhere after line 6.

  • @kiwi
    Have you been able to solve this in any way? We have the exact same problem with our serial device which gets registered as xhci_hcd, and no ttyUSB* device is added when plugging in the device. I have tried all of the USB ports, getting the same result.

    We have tried to move the dtoverlay=dwc2,dr_mode=host line to be included under the [all] line as @smieschek suggested.

    Everything is working perfect when running a RBPi3 running emteria.OS v7.3.0 but not with our RBPi4 running emteria.OS v11.3.0.

    Does anyone have an update on this?

  • @linusekstrom Another customer had a similar issue and we were able to fix it. Can you try nightly v11.6.10 for RPi4 and see if your device gets listed?

Sign In or Register to comment.