PPP Widget 3 on Raspberry-Pi 4

edited April 21 in Supported devices
Hi!

I'm running emteria v11.3.0 on a Raspberry-Pi 4. I'm trying to install `PPP Widget 3` to be able to use a Huawei E3372 LTE USB 3G/4G modem dongle as described here : https://emteria.com/kb/setup-ppp-widget-application

I found on this forum that the Play Store is not available on emteria on Raspberry-Pi, so I tried manual installation via `adb install`, I tried installing using stores like Yalp and Aurora Store. I always get the following error when using the widget on the home screen: "Installation of local APK files is not supported. Please use Google Play!" (https://i.postimg.cc/Ssg2NPYj/ppp-widget.png)

In an attempt to install `PPP Widget 3` I also tried to install `OpenGApps Downloader` from F-Droid, but when I use it, I get:
opengapps_downloaderMainActivity: Can't get root access
opengapps_downloaderMainActivity: java.io.IOException: Cannot run program "su": error=13, Permission denied

Does anyone know a way I can install `PPP Widget 3` on emteria on a Raspberry Pi 4 or if there is another way that would allow me to use a USB 3G/4G modem dongle?
Tagged:

Comments

  • Hi @bart ,
    The PPP Widget is a third party app that is not developed by us. It seems that it changed since the time our article was written. We would be happy to have it working again and are willing to help with the integration. Maybe you can reach out to the developer to get him involved.
    I don't have an alternative for now, but we are looking into other options.
Sign In or Register to comment.