How to update config.txt using ADB wifi

edited January 25 in OS features

Hi, I am trying to update boot/config.txt, i can connect to the rp4 over ADB wifi in developer mode, I can also pull the file and I edited it on my local windows 10 PC, but when I try to push it it will not go. Can anyone help? I have tried many things.

C:\>adb push D:\temp\config.txt /boot/config.txt
D:\temp\config.txt: 1 file pushed, 0 skipped. 2.1 MB/s (449 bytes in 0.000s)
adb: error: failed to copy 'D:\temp\config.txt' to '/boot/config.txt': remote couldn't create file: Read-only file system

I don't know how to change file permissions on that file because chmod doesn't work, it seems to already be chmodded to 777 anyway, I tried something about remount and mount but that didn't seem to work either. If anyone can outline how to do it that would be great.

Comments

  • I want to update this post. I have finally figured out how to do it. I used the command su. then mount -o rw,remount /boot this can be closed now

  • @telica there is also "adb root" which should allow to use chmod/chown. With "adb shell" and afterwards "su", you are also root on the device. Remounting is needed if a partition is mounted read-only.

Sign In or Register to comment.