Shrinking an Image

edited March 15 in OS installer

Hi. I'm currently running the OS on a Raspberry Pi 4 using a 16Gb card but what I also like to do is take periodic backups of the card so that in the event of a card/os failure, I can restore from a saved image.

Problem is, with 16Gb cards, over time that can take up quit a large abount of space. As with other Raspberry Pi images, I've used a program called PiShrink to reduce the file size and tried it on one of my images. It seem to do the shrinking okay but when I put the image onto a 16gb card and attempted to start the Pi, the green light kept flashing 4 time and system wouldn't boot.

I tried another shrinking and what I have noticed is that at the very start of the process, it refers to '/etc not found so autoexpand will not be enabled'

Any suggestions

Thanks

Declan

Comments

  • @dbarry722
    Welcome to the forum :)

    I don't know about PiShrink, but I assume it's specific to RPOS and that it misses some Android specific partitions. I would like to suggest another approach: have you tried to just zip the saved image?

Sign In or Register to comment.