Bluetooth Crashes v11.11.00 RPi 4

I had v11.8 running fine on my RPi 4 with Bluetooth rock steady.

I updated the unit to v11.11 and now the Bluetooth crashes and won't start successfully.

I had some OS alert messages stating that the power supply was low so I changed it to a more powerful one but that hasn't changed the Bluetooth behaviour.

It looks like the unit is trying to start the bluetooth radio but doesn't manage to do it successfully.

Has anyone else experienced this problem?


  • Hi @Binary_Forge
    Sorry to hear that. I'll have a look next week, if we changed anything with regard to BT between v11.8.0 and v11.11.0
    Can you take some logs after a crash happens? -
    Have you tried v13.3.0? Does it have the same issues? Our development is mostly focused on Android 13 nowadays. Any fixes and new features can be expected there first.

  • Thanks for the reply @smieschek, I'll provide some logs if I can. Is there a specific way to do this or are you happy to receive ADB output?

    How do I upgrade to v13.3.0? Will I need to re-flash the SD card or is there a way to upgrade through device management?

  • @Binary_Forge ADB is perfect; maybe also dmsg for kernel logs
    Unfortunately, you have to reflash to get from v11 to v13 :(

  • @smieschek I reflashed over the weekend and upgraded to v13.3.0 and although it was quite painful (there were a lot of device restarts as I made settings changes) I've finally managed to get the device back up and running.

    I believe the problem still exists with v13.3.0 though, my device constantly cycles through trying to start Bluetooth, failing, and then trying to start the service again.

    I'll get some ADB logs when I'm next in the office again tomorrow.

  • @smieschek I've attached the adb log with a few cycles of the Bluetooth service restart problem. I also tried to access the Emteria Settings app on the device at the very end of the log and this is where the device restarted on me.

    It does this on a regular basis, so much so now that I can't open it to turn on SSH access so I can't get you the dmesg log I'm afraid.

    I'm going to try downgrading to 11.8.0 again to see if the problem persists.

  • @smieschek For reference (if it helps). I downgraded to v11.8.0 this afternoon, the Bluetooth is operational again and the random restarts when changing settings (either Emteria or Android) are no longer observed.

    This would suggest to me that it's not a problem with the Pi or with the SD card I'm using unless there's something else I can test to prove one way or the other.

  • @smieschek Is this problem of Bluetooth crash solved yet? I was hoping to upgrade to v13.3.0 but due to this issue haven't been able to do so.

  • @dexter There were several issues with BT. We've already fixed a few and it should work better with v13.3.0. But we know that there are still issues with BLE devices. What kind of device and connection are you trying to use?

Sign In or Register to comment.