when entering a license "error contacting server request was invalid"

A RPi3B+ that has worked for years starting showing an invalid license. I tried both the license number and email to activate the device again. Both failed with the following error.

"error contacting server request was invalid"

I pulled the flash card and reinstalled the OS from scratch and during the setup when promoted to enter my license email and password I get the same error.

What can I do to get past this licensing issue? There doesn't seem to be any support option even for paying customers.


  • Hi @MLevin ,

    I've created a free starter subscription for you and moved the device to the corresponding group. Please try to reactivate your device with the same activation code or your credentials now.

    For private users we can only offer best effort support through our forum, sorry. If you have a business case and would like an SLA, please reach out to sales@emteria.com

  • Same problem here with a Raspberry Pi 3 B+.
    "Error contacting server request was invalid" as I try to connect with username and password.

  • hi @ottogiugno
    you haven't redeemed your starter subscription, please see https://emteria.com/kb/starter-subscription

Sign In or Register to comment.