RPi4 B Camera

edited January 26 in Supported devices

I have installed the latest version of Emteria with a RPi camera connected, via ribbon cable to the board. When I enter the camera app it crashes and when I use any video calling software the camera is not accessed. I submitted a bug report already but I can provide logcat log. Any help?

Comments

  • @1parkerj1 Which RPi model and which emteria.OS version? What date did you submit the bugreport?

  • edited January 30

    Raspberry Pi 4B, Latest version. I think 26/01/24 in the afternoon if that helps

  • hi @1parkerj1
    Sorry, I need to ask again about the version, cause latest is somewhat ambiguous. Is it v14.2.0 or what's the latest for you?
    The bugreport didn't come through - no bugreport for rpi4 that day. Can you try resending or uploading the logcat?

  • edited February 6

    sorry, it was v14.2.0. I just resubmitted a bug report after trying it again. Reinstalled v14.2.0 and still having the same problem. (it isn't a hardware problem because the camera works on lineage os)

  • @1parkerj1
    I can see the camera app crashing, but not really why. Can you also provide the "dmesg" log?
    Which RPi Camera model is it? - there are at least 4 different and you might need to adjust to the correct overlay.

  • @smieschek thanks for getting back! I don't know the exact model but the silkscreen says "Raspberry Pi Camera Rev 1.3" I think I got it on amazon. Anyways, I've tried multiple of the same camera and different ribbon cables.

    The dmesg:

  • @1parkerj1 I think that's an Omnivision 5647 sensor. Take a look into the config.txt on the boot partition. There should be an overlay entry which loads imx219. Change that imx219 to ov5647 and try if it works.

    Afterwords you can to it in config-override, but for testing it's okay to change config.txt directly. You just need to be aware that any changes to config.txt are gone after an update.

  • changing the overlay in the config file worked, you were very helpful
    Thank you :smile:

  • Hey everyone! Just wanted to share that DOOGEE Coupons Code is now available for some amazing discounts on rugged smartphones. Don't miss out on these savings – grab yours today and upgrade your mobile experience without breaking the bank! Happy shopping!

Sign In or Register to comment.