Waveshare 7” (C) not working Rpi4b 13.5

edited January 31 in Supported peripherals

Hello,

I am trying to get my waveshare 7” (c) screen to work on my raspberry pi4B but having no success.

I have added the strings that waveshare state in the config.txt. This fixed the resolution for me, but all I get is the Uboot show up on screen, that shows all the commands but then the screen doesn’t display anything.( where the emteria logo usually shows).

I’m on the latest version of emteriaos, I get a display as normal if I plug in a normal hdmi monitor.
I’ve tried to Google and search for stuff to no avail.

Link to the screen I’m trying to use: https://www.waveshare.com/wiki/7inch_HDMI_LCD_(C)

The string I’ve added to config:

hdmi_group=2
hdmi_mode=87
hdmi_cvt 1024 600 60 6 0 0 0
hdmi_drive=1

This is my first time with any kind of scripting and first time with a raspberry pi, so I apologise in advance- i have no idea what I’m doing 😂

Any help is really appreciated, I refuse to give up as I’m planning on using this as a Rash dash in my track car.

Comments

  • @Shen
    Try changing "dtoverlay=vc4-kms-v3d,noaudio" in config.txt to "dtoverlay=vc4-fkms-v3d,noaudio"

  • Hello mate, thank you for the help!

    With all the back and forth with the sd card it appears to have corrupted the drive, therefore I need to do a fresh installation 🤦 when I have time I shall try again and get back to you

  • edited February 7

    @smieschek

    Thank you for the help, i cannot seem to see exactly "dtoverlay=vc4-kms-v3d,noaudio" in the config.txt Below i have pasted the exact config file:-

    "# This file is generated and maintained by emteria

    Please do not modify it manually, as your changes will be overwritten during the next OS update

    If you need to add or overwrite something, please add your changes to config-overrides.txt file

    audio

    dtparam=audio=on

    Following definitions only apply when booted on Compute Module 4

    [cm4]
    dtparam=i2c_vc=on
    dtoverlay=i2c-rtc,pcf85063a,i2c_csi_dsi
    dtoverlay=dwc2,dr_mode=host
    otg_mode=1

    Following definitions always apply to all devices

    [all]
    kernel=u-boot.bin
    arm_64bit=1

    audio

    hdmi_force_edid_audio=1

    disable kms audio path and force bcm2835 card 0 = hdmi card 1 = headphone jack

    dtoverlay=vc4-kms-v3d,cma-384
    dtoverlay=cma,cma-384
    dtoverlay=rpivid-v4l2
    disable_overscan=1

    add support for official 7" touchscreen

    dtoverlay=rpi-backlight
    display_auto_detect=1

    add overlay for camera sensor and use firmware with codecs

    dtoverlay=imx219
    camera_auto_detect=1
    start_x=1

    temporarily increase the CPU frequency on boot

    initial_turbo=60

    enable serial console and pin core clock fixed to 500MHz

    enable_uart=1

    load user-defined overrides for this config

    include config-overrides.txt
    "

    i tried editting "headphone jack
    dtoverlay=vc4-kms-v3d" to what you wrote above to no avail either i noted it just replaces the "fkms" back to "kms" after you try a boot , any suggestions?

    Cheers

  • @Shen
    Do you have adb access? In adb shell you can try: "setprop persist.rpi.vc4.force fkms"

  • edited February 25

    @smieschek

    After alot of faffing, i got into adb via Wifi, ran as the screenshot below. reconnected the waveshare screen and nbothing has changed, did i set it correctly?

    One thing i did notice, with the rpi connect to a generic moniter and the waveshare also connected via usb ( not the HDMI) the touchscreen capibility is working, so i just seems to be the display side thats the issue. not sure if this helps,

    Thanks

Sign In or Register to comment.