Some Pi 3B+ do not boot - Different PCB Layout

We have been installing Emteria on 3B+ for some years now. The latest batch of 3B+ PCBs have a slightly different layout in that near the HDMI port there is an inductor instead of what we think are capacitors. We can install and run RaspberryPi OS but when we flash Emteria, we get 3 slow flashes and 7 fast flashes on the green LED. Does anyone have any ideas? We have tried the latest image and the older one that we have used for 80 odd 3B+'s before.



  • Hi @workinonit
    Is the inductor/capacitor the only visible difference or is the print on the new PCBs different so that they are distinguishable?
    Can you take logs via UART? -

  • Thanks, I have done as you say and although I can get a log on the "Old" Pi absolutely nothing comes up on the "New" Pi, not even a CR. I just get the red LED on and the green one flashing slowly 4 times and then fast 7 times. It then repeats this.

    The screen printing and component layout are slightly different on each of the Pi. I have attached some images. The under side that has the SD Card in it is the "Old - Good" Pi and the top view with the R47 item bottom right of the broadcome chip is the "New - Bad" Pi. There are a few other differences.

  • @workinonit Thanks for the images. I can see that the PCB is different at several locations, but it's basically the same "version" so I would assume it should work. Have you tried to boot RPOS on the new PCBs? - Just to rule out faulty hardware.

  • Yes, RPOS boots fine

  • I have a bit more information. I have found a source on the web that explains the flashes I get on the green LED. I get both of these in succession:

    4 flashes - start.elf found but not launchable (corrupt)

    7 flashes - kernel.img not found

    So I copied a few files over from the RPOS SD card that did boot and I got it to boot the Emteria card. However, it wouldn't start emteria properly.

    Does anyone have any ideas? I am going to try putting the Emteria files back one by one to see if I can fix it and will report back.

  • edited March 1

    Interesting, I will relay this information, but I'm not sure if and how we can proceed / help for the time being.

    @workinonit which version of emteria.OS are you installing on the devices?

  • We have tried our normal install which is 1.3.39 and the latest one which is 7.6.0

  • Hi,

    I have the same exact problem with my RPI3 b+ all other OS are working fine, but only Android won't boot.

    I have the same RPI board as well. And I have tried the Beta and Nightly editions as well.

    Best regards,

  • edited March 15


    Mine as well, after done active and reboot, then it was stuck at boot screen at, [brcmfmac]: power management disabled.

    Best Regards,

    I got plug in the keyboard, so after i unplug, can boot already.

  • @workinonit / @tcst
    Do you have any USB devices connected? Does it help to unplug them?

  • edited March 28

    No, nothing connected. We still have the problem.

    The problem is that we have 80+ machines out there with 3B+ installed and if the Pi goes wrong there is nothing we can do to fix it. RPI4 is not an option at present.

    I can send you a Pi 3B+ "New style" if this helps. We have many of them and they are useless to us now.

  • @workinonit it would certainly help, but I must admit, that it will probably take a day or two to assess what isn't working and what needs to be done to fix it - and the last part is hard to estimate beforehand. We would need to charge some T&M for that. If you are interested, please reach out to to work out the details.

Sign In or Register to comment.