Emteria 14.2.0 Official Display Isn't Working Anymore

Sadly on the new 14.2.0 beta or the later Live release the Official 7" display is no longer working.
It used to work in the previous versions (pre 14.2).
Is this a known issue?


  • This was on a rpi5 BTW

  • @simpz that's strange. The display never worked for us. Does it work out of the box with 14.1.0 for you?
    Do you have any display output with 14.2.0 or is it just dark?

  • It worked out of the box as I remember (don't think I toggled anything) with 14.1 but is just dark on 14.2.
    It works with Raspberrypi OS to be clear.

  • We are looking into it, but couldn't reproduce it. The display is dark on all versions in our lab. Might take some time to figure this one out, sorry.

  • Works fine for me with 14.1.0 Beta written with the emteria.OS installer to a micro-SD card. The pictures attached of bootup and then the wizard with touchscreen working fine.

    14.3.0 does power up the screen (well the backlight comes on) but nothing is displayed.

  • For some reason won't let me upload the second image.

  • @simpz Interesting. The RPi5 has this smaller connector for the touchscreen compared to RPi4. Do you have a direct cable or some adapter in between?

  • https://thepihut.com/products/display-adapter-cable-for-raspberry-pi-5

    This cable is needed to connect the RPi5 to the official display.

  • I guess the easy way to test the display hardware is to test boot with Raspberry Pi OS which has out of the box support for this display.

Sign In or Register to comment.