Windows Installer Won't Login

Trying to login with my emteria account and it takes about 10 minutes "thinking" with a greyed out authorize button and then finally displays "login failed - try again" in red.


  • Just tested it with 2 different PCs and it seems to work fine in our setup. Our server logs show that you were correctly authenticated each time. Did it work out eventually?

  • Same is happening to me, except that it does not wait for 10 minutes. It comes up with the red login failed immediately. I have tried this on 2 separate email accounts

  • Can you please provide us some more details about your environment (OS version)?

  • Windows 10 Professional x64, running as administrator

  • edited September 2017

    Ah it worked now !! Don't know why it didn't at first. Maybe I just needed to wait a little for whatever system your installers accesses to recognize my new login. If it helps, after first failing to authorize, I waited about 7 or 8 minutes before trying again and then it worked. Thanks :-)

  • Thanks for your feedback! We are glad it is working as intended.

  • My windows installer is giving the same error.
    I Can't login

  • edited October 2017

    @Gooden, can you please login to the website first?
    EDIT: If it works, login to the installer again.

  • Now that i logout i can't login again

  • Ok working.
    I think i know the error. When I made my account I inputed a pass with no Letters. only numbers. and it can't be i think.


  • @Gooden, thank you very much for this information. It might help us solving this issue.

Sign In or Register to comment.