VPN is not working

Hi,
I'm using some VPN application which was working properly under RTAndroid.
Since i switched to Emteria OS it doesn't work, VPN says it's connected with that key on the notification bar however my ip address doesn't change at all.

Any suggestions?

Comments

  • edited October 2017

    You all can download Hotspot Shield off Google play.
    When you turn it on you will notice that your ip address doesn't change.
    The screenshot describes the problem as there is no sent or received traffic.

    vpn.png

  • I've just invested some time trying out different apps without any success. There are no errors being thrown in the logcat :confused: I have very little knowledge in networking, so I don't even know how to debug it. Might be interesting to compare the logcat output between RTAndroid and emteria...

  • Thank you for replying Igor,
    I have tried many apps too and non is working, the traffic doesn't pass through the VPN app although it says it's connected.
    Therefore all installed apps act as if there is no VPN.
    I think that problem is cause by removing some feature from RTAndroid
    I suggest that you bring back all the removed apps like
    Phone/Dialer
    Cellular Data
    Phone Call Management
    Although they seem to be useless but they somehow affect some other app.

  • @roxette, is this application (Hotspot) working on other devices? Or do you know if it was working on RTAndroid? It looks like the VPN server is dead, so I'm not sure what to debug.

  • edited October 2017

    Hotspotshield.png

    Yes it was working on RTAndroid.
    Actually it's still working on some other Android image ... check screenshot.
    Perhaps you can debug it using that image, i think you know which image i'm referring to.
    The problem is your ISP might blocked VPN.

  • That the problem is caused by the new kernel. If I replace the new kernel (4.9.58) by the old one (4.4.50), but still use the latest emteria.OS, the app is working fine.

    Unfortunately, I see no difference in the kernel configuration between those two kernels. Maybe the ip filter rules have to be configured in a different way... More debugging is needed. I'll keep you up-to-date ;)

  • Mh, just noticed: with the old kernel the data counters are increasing, but I can't access any pages in the browser...

  • image.png

    image.png

    image.png

    image.png

    image.png

    Hi Igor :smile:
    The application works flawlessly using kernel v4.4.80.
    As you can see i can't be in Russia and Germany at the same time. :smiley:

  • I did some more testing today. It seems deactivating IPv6 helps, but only until the next reboot. There are a lot of IPv6-related bugs for VPN reported online, so I assume it is something caused by the kernel. I'll keep an eye on it.

  • edited October 2017

    https://youtu.be/q1q5RgaAMfI

    No problem, it's not an urgent feature .. you can add it to your list.
    Although i have another challenge for you :smile: , it's the application in the youtube video.
    I'm using a Vodafone broadband USB stick which connected to the RPi via USB port, i was able to establish a connection using that app however i can't browse the internet.

  • Hey, Can I configure ExpressVPN too on Emteria OS? Just like you configured BlueVPN?

  • try this guide it will work for you
    https://fastestvpn.com/android-vpn

  • Hello, has anyone tested the Melon VPN? He's the only one that works for me. And I'm going to install the OS today, should I select any option in the installation for the VPN to work? thks...

  • Hello,

    has the VPN issue been resolved in the latest Emteria OS version ??
    Because I did not work with Hide Me either. He connected according to the app (Hide me), but when I showed the IP address to me, he always said Germany, even though I was dialed in the Netherlands.

    bye

    Jörg

  • No updates so far. We have a newer kernel which might solve this issue, but isn't stable yet for public release.

  • Which VPN you are using? Same issue is occurring with me but after roxette's suggestion I downloaded Hotspot Shield. Before this, I was using Vypr after reading an article regarding VyprVPN review,

  • TofTof
    edited August 13

    I downloaded Emteria because I was looking for a stable Android build to use for my RPI3.
    My project was to create a kind of smart tv/iptv device as I am not too keen on Librelec and Kodi (the other builds I tried were giving a super laggy stream).
    I had the same issue you had and found an easy workaround. Install this app : https://play.google.com/store/apps/details?id=com.jfsoftware.ipv6autodisable&hl=en_GB.
    This will automatically disable the IPv6 whenever your device connects to a wifi (just hide the notifications as it gets a bit annoying).
    Then with Tasker I added a process that does this: Launches my Vpn app at boot up, waits for 10sec (the time needed for my app to connect to a server) and then launches my Iptv app. All connects flawlessly! I added Flirc to the equation and Bob was my uncle! You can find all the apps on Apptoide if you need! Hope it helps.

  • Helo! Here i have same problem... I tried The app for deactive The ipv6 but The problem persists... VPNs dont work... Dont have any other way to put it to work in Emteria??

  • What version of emreria you are using? And What app vpn? Because Here i have tried this app for disable ipv6 but even with disabled none VPNs are connecting and work... Please... How i can use vpn with Emteria??

  • @Tof said:
    I downloaded Emteria because I was looking for a stable Android build to use for my RPI3.
    My project was to create a kind of smart tv/iptv device as I am not too keen on Librelec and Kodi (the other builds I tried were giving a super laggy stream).
    I had the same issue you had and found an easy workaround. Install this app : https://play.google.com/store/apps/details?id=com.jfsoftware.ipv6autodisable&hl=en_GB.
    This will automatically disable the IPv6 whenever your device connects to a wifi (just hide the notifications as it gets a bit annoying).
    Then with Tasker I added a process that does this: Launches my Vpn app at boot up, waits for 10sec (the time needed for my app to connect to a server) and then launches my Iptv app. All connects flawlessly! I added Flirc to the equation and Bob was my uncle! You can find all the apps on Apptoide if you need! Hope it helps.

    Please friend, provide me some information like :

    • What version of Emteria OS you are using with VPN working ?
    • What VPN app you are using ?

    Because i have the same project of you (Turn RPI into an TVBox for IPTV etc) but for me , my provider has recently blocking the service and only works OK with VPn ...

    But i have tried install the "IPV6 Disable" as you indicate above...the IPV6 is disabled but the VPN still not working... it's OK, the Key is on the toolbar, but ...not working...

    So, if you can provide me more informations of how it working for you (with versions of Emteria and apk VPN you are using) i can try it here too....

    If i cant enable VPN, the only option for me is buy an real TVBox product.... but i like the Emteria OS...the VPN is the unique problem here....

    Please, help me with these informations ...

  • Hello, sorry for the delay. I am using Ipvanish and I was using the latest stable version of Emteria(from the installer, near the version number you will see either Stable or Beta). For the Iptv app, Iptv Smarter Pro with a Iptv subscription I bought. PM for more details.

Sign In or Register to comment.