Touchscreen drivers just don't understand how to download


  • This is a GPIO Screen

  • Are gpio touch screens an option? I have a 5 inch and a 3.5 inch gpio touch screen and would like to know if it would work, the 5 inch has HDMI and gpio touch, the 3.5 inch is just gpio for screen feed and and touch. Very interested to know if this would work and if so how to proceed. I am aware this is most probably a no , just asking to be sure

  • I also have this screen and would like to know this answer. I would happily purchase Emteria if this display can be supported as touchscreen.

  • me too please

  • We don't have this kind of screen at our lab, so I can't say for sure. But if there are drivers available, use them in the same way you would do it in Raspbian (with required Android adaptation). You can load modules, configure GPIO and do whatever you like.

  • The drivers are located at and are installed by running the LCD5-show script. I do not know what would be required to install this on Emteria. Can you provide us with some guidance please? Thank you.

  • Those are not drivers, but rather script files for the screen configuration. You can check what those scripts do and apply the desired configuration manually.

  • @kalkov said:
    Those are not drivers, but rather script files for the screen configuration. You can check what those scripts do and apply the desired configuration manually.

    Actually they aren't all scripts.and make calls for XORG

    echo "need to update touch configuration"
    sudo apt-get install xserver-xorg-input-evdev
    sudo mkdir /etc/X11/xorg.conf.d
    sudo cp ./usr/40-libinput.conf-HDMI7B /etc/X11/xorg.conf.d/40-libinput.conf
    sudo reboot

    Non of this is compatible with android.

  • Development in touch operation. I accidentally found that touching in RECOVERY mode works like a dream. Restarted from RECOVERY mode, when OS is loaded, the touch is reconnected and unreliable. Does anyone know how to resume good operation under RECOVERY for OS? Professionals can certainly solve it. This is a very high task for me.
    Kalkov will certainly be able to handle it as it does in RECOVERY.

  • I was upgraded to the latest version - 0.6.0 but the touch quality did not change. The solution is located in RECOVERY, it works the touch as it should. The solution can only be done by anyone who wrote a program. I hope to read my post and resolve this long-awaited problem.

  • Funny thing is I did try manually putting in the code without the stuff that needing to be installed and it just broke android. Don’t forget you can get source files of the dev input which then could work, but I had no luck.
  • I look forward to Kalkov's response, but he did not reply to my letter addressed to me either. He certainly knows how to solve it.

  • I read some comments about touch not working that good. This type of screen is not capacitive but the other type. You need to push hard to get it to work :wink:
  • I have a restive screen.

  • and I've tested it in raspbian and it works fine.

  • Kalkov, It's up to you fixing this issue no one is able to install the xserver-xorg-input-evdev. We'll be waiting for your response.

  • Maybe there is a way making this screen usb which tricks it to be compatible but there too many issues with that.

  • This is the script for LCD5-show made for the screen thats being used. sudo rm -rf /etc/X11/xorg.conf.d/40-libinput.conf sudo cp -rf ./boot/config-5.txt /boot/config.txt if [ -b /dev/mmcblk0p7 ]; then sudo cp ./usr/cmdline.txt-noobs /boot/cmdline.txt else sudo cp ./usr/cmdline.txt /boot/ fi sudo cp ./usr/inittab /etc/ sudo cp -rf ./usr/99-fbturbo.conf-HDMI /usr/share/X11/xorg.conf.d/99-fbturbo.conf sudo mkdir /etc/X11/xorg.conf.d sudo cp -rf ./usr/99-calibration.conf-5 /etc/X11/xorg.conf.d/99-calibration.conf nodeplatform=`uname -n` kernel=`uname -r` version=`uname -v` if test "$nodeplatform" = "raspberrypi";then echo "this is raspberrypi kernel" version=${version%% *} version=${version#*#} echo $version if test $version -lt 970;then echo "reboot" else echo "need to update touch configuration" sudo apt-get install xserver-xorg-input-evdev sudo cp -rf /usr/share/X11/xorg.conf.d/10-evdev.conf /usr/share/X11/xorg.conf.d/45-evdev.conf echo "reboot" fi else echo "this is not raspberrypi kernel, no need to update touch configure, reboot" fi sudo reboot

  • edited November 2018
  • My friends! This is a resistive screen, which is really less sensitive than capacitive. But it works well, as close as the capacitance. I found this when I tried in RECOVERY. It worked perfectly. This status must be passed on to the Android system.
    If Kalkov solves this, he will solve the problem of many of us.
    Only Kalkov does not appear. Unfortunately, we can not do anything else, we are waiting.

  • edited November 2018
    That’s a usb controlled screen.
  • All the screen over here are GPIO
  • Hey obero, I don’t really understand your point here. If your able to clear it up that be great.
  • This is not a question. The question is how to work well under Emteria.

  • Which part is not clear?

  • Packages like xserver-xorg-input-evdev won't be compatible with Android. If obero's touchscreen is working in the recovery mode, it should also work with emteria.OS. However, I really don't understand what exactly is the problem there.

  • There are two things mixed here, mine is a special topic, we're discussing elsewhere.

This discussion has been closed.