Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

GPS Module

Hi all,

I'm playing a little bit with the Raspberry PI and found Emteria while searching for information about the Raspberry.
Good job !
It runs almost stable and I was able to install Google Play.

Now I'm interested to use the tiny Raspberry as navigation system in the car. Unfortunatelly GPS dosn't work. I connected a GPS Mouse via USB and the installed TomTom App dosn't found the GPS module.

Is there any possibility to get GPS working?

Regards
Supergrobi

«13

Comments

  • Hi Supergrobi. Thanks for your feedback. Can you please elaborate on "it runs almost stable"? What exactly is bothering you?

    We have no experience with (USB-connected) GPS modules. If the module isn't detected at all, there is probably a driver missing. If it is detected by the Linux kernel, but not by Android, it's probably HAL issue. We have no GPS modules here to test, so if you happen to find out what is causing the problem earlier than we do, we will be happy to fix it.

  • Hi,

    I have sometimes trouble with installing Apps from Google Play. During downloading the App the Raspberry stops working. After a reboot the installation goes on and works well. Happened 2 times until now.
    But it could be that I made a mistake. I'm totally unexperienced with Android.

    Regarding the GPS Module: Do I understand you right that USB GPS Modules are supported by Emteria if the driver is included in the Linux Kernel?
    If so I will buy a other Module and try it again. Do RS232 Modules work as well?

  • Well, we have little impact on the GApps / Google Play installation flow. Maybe it is a memory issue or Google Play Services just need to finish the background initialization.

    Regarding the GPS module, no you don't need to buy a new one. Try finding out what driver is used for this one (how would you use it in Linux) and we will include the driver in the next release. We didn't try any GPS modules so far. Neither USB nor RS232.

  • OK understood :-)
    Under Raspbian Stretch the USB GPS-Mous works fine, so I will find out which driver is needed.
    Thanks for your help!

  • Hi :)
    I have solution how to run Usb gps on android.
    You should try this:
    https://github.com/freshollie/UsbGps4Droid

    I use Holux 215 gps-mouse and all works great.

    Best regards

  • Hi @marciling, thank you very much for your feedback. So you are using this app together with a USB dongle and emteria.OS?

  • Yes :)
    Usb dondle (Holux215) + emteria.os (0.3.0) + usbgps4Droid (2.1.3) works fine.

  • Hi marciling,

    Thanks for this tip :-)
    I have installed the app but it don't work.
    I get the error:
    UsbGps stopped
    Reason: Mock locations disabled in settings

    I have no clue what's a Mock location and what I have to set in the settings that the app will run.

    Has anybody an idea?

    Thanks for help

  • edited October 2017

    @Supergrobi, Go to Settings - Developer options - Select mock location app

    By the way, did you try to search for USB GPS on Google play?
    There are several apps over there, you might find another app that works.

  • @marciling, which navigation app are you using?
    Is it TomTom or Sygic?

  • I use sygic.Usbgps4Droid must be version 2.1.3 because earlier version has problem with new android security level.

  • Hi roxette,

    Thanks for the help with Mock location settings, it worked and the error message is gone.
    Unfortunately I get still no connection to the USB device. I guess my USB GPS mouse is very unique :-) Tomorrow I have a chance to test a different one.
    I will post the result here if it works ore not.

    I installed TomTom just to test it if I'm happy with it. Once I get my GPS working I will see if TomTom is usable on the Raspberry. I'll keep you updated.

  • IT WORKS !!! :-)

    After connecting a different GPS Mouse UsbGps4Droid shows my position.
    Unfortunately TomTom is the opinion that I have deactivated GPS :-(

    Has anybody an idea how I can TomTom teach to use the UsbGps4Droid position?

  • Hi all,

    I installed TomTom completely new and now it works. No clue what went wrong.
    Now I'm happy :-)

    Thanks to all for the excellent help to get the GPS running.

  • @Supergrobi, so now you are happy and willing to purchase a license? :wink:

  • After I have tested the navigation system on the Raspberry and it runs stable we can talk about it :smile:

  • edited November 2017

    Usbgps4Droid app up and running, data coming in from the gps ant. So is there a trick to get it to communicate with other apps? I'm also running a holux 215 ? I've tied several settings with out luck....

  • edited November 2017

    What are the ways i can get GPS data into a Raspberry Pi Android installation . Is the USB route the only way ? Also ,what is the best USB GPS unit for this android Raspberry Pi setup

  • edited November 2017

    @IOTGuru said:
    What are the ways i can get GPS data into a Raspberry Pi Android installation . Is the USB route the only way ? Also ,what is the best USB GPS unit for this android Raspberry Pi setup

    bluetooth_gps.jpg

    No, USB GPS is not the only way.
    I share my old phone integrated GPS module connected to the Raspberry pi via bluetooth :smile:

  • edited November 2017

    sat_fix.jpg

    sat_fix1.jpg

    sat_fix2.png

    GPS satellite fix :smile:

    You need to install Bluetooth GPS Provider on Emteria OS to interact with the phone built-in GPS module.

    By the way i'm not using a Samsung phone as the app claims, that was already explained in another thread LOL.

  • @roxette can you explain what i have to do to use gps position of a old phone to emteria os please ?

  • edited December 2017

    @jonas7782 , it's as described in screenshots.
    - On your phone you install an application that acts as a server to share the integrated GPS module to Emteria OS via bluetooth.
    - On Emteria OS you install Bluetooth GPS Provider app.
    - On Emteria OS, Enable Mock GPS Provider.
    What is your phone brand/model?

  • USBGPS works. Sends data, but applications do not have access. They are inactive while active.
    I tried: Waze, Torque, Navigator, TomTom Go.
    and two USB GPS, but it was both.
    I tried the UsbGps4Droid-2.1.5 program. The program recognized both Gps

  • @roxette now i have iphone 6 ,but i have "old" samsung galaxy s5 that i can use
    thanks for you help i will try :)

  • @jonas7782 , no problem ... if you were able to make it work then please post screenshots to help someone else :smile:

  • Did someone make any effort in using an USB-GPS-Dongle?
    I also tried several APPs and tips but nothing works fine. The tip to set the SELinus on disabled makes no difference.
    I would be pleased if someone could tell how the USB-GPS works stable.

  • A couple of questions, has someone used a gps module for the gpio pins? also, somebody has managed to establish bluetooth connection between raspberry and a mobile xioami?

  • I tried also to use a bluetooth GPS provider on my Redmi 4 but unfortunately none of the apps is working. The apps are not able to access the phone's GPS. I will try to buy a USB GPS and test it.

  • Hi,
    i have a problem to find the USB port with USBGPS4droid and pl2303gpsinfo i cant start it but after a click on start gps he does nothing. every test i have enabled the mock gps for these apps.

  • We have purchased a GPS dongle. It will be tested in the next days

Sign In or Register to comment.