Windows installer v0.6-16 failures

dubdub
edited March 12 in Installer

I have Installer version 0.6-16 on Windows, and was able to flash the latest Emteria image to a SanDisk Ultra Class-10 A1 SD card. When I put this into RPi-3 it booted to the Emteria logo and hung. After waiting for 30 mins we tried reboot, and again, but no success.

So I went back to install the last 'stable' release to another SanDisk 16GB Class-10 card. Unfortunately this time the installed crashed out. I reformatted the original card and tried again with 4 different versions of image files, but all fail during the unzip/writing process. The most recent log file is below.

Can anyone advice what's going wrong here?

The only Linux machines I have access to are Raspbian on RPi. I presume there is no Linux installer for these? The one I tried was x86 only.

Thanks in advance for any help.


Starting emteria installer v0.6-16-gc6254ca
Detected SSL support: true
- runtime version: "OpenSSL 1.0.2q 20 Nov 2018"
- build version: "OpenSSL 1.0.2j 26 Sep 2016"
Opening remote connection
Refreshing drives
Ignoring system drive "xxx"
Found 1 drive(s)
Checking for OEM config
No OEM config available
Started downloading "package.json"
Using path "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer/rpi3-v0.6.1/package.json"
Finished downloading "package.json"
Started downloading "boot.zip"
Using path "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer/rpi3-v0.6.1/boot.zip"
Finished downloading "boot.zip"
Started downloading "oem.zip"
Using path "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer/rpi3-v0.6.1/oem.zip"
Finished downloading "oem.zip"
Started downloading "system.zip"
Using path "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer/rpi3-v0.6.1/system.zip"
Finished downloading "system.zip"
Finished DownloadWorker
Flashing on raw "\\\\.\\PHYSICALDRIVE1"
Initializing package base at "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer\rpi3-v0.6.1"
Drive: "Generic STORAGE DEVICE USB Device" with 15931539456 bytes
Raw at "\\\\.\\PHYSICALDRIVE1"
Starting step 0 : Reading package
Finished step 0 : Reading package
Starting step 1 : Verifying files
Finished step 1 : Verifying files
Starting step 2 : Preparing
Diskpart output: "\r\nMicrosoft DiskPart version 10.0.16299.15\r\n\r\nCopyright (C) Microsoft Corporation.\r\nOn computer: user1-MOBL1\r\n\r\nDisk 1 is now the selected disk.\r\n\r\nDiskPart succeeded in cleaning the disk.\r\n\r\nPlease wait while DiskPart scans your configuration...\r\n\r\nDiskPart has finished scanning your configuration.\r\n"
Finished step 2 : Preparing
Starting step 3 : Opening to write
Finished step 3 : Opening to write
This drive seems to have 31116288 sectors
Found 4 partitions to write
Processing partition "boot" using LBA of 2048
Size determined from zip: 65011712
Partition will occupy 126976 sectors
Processing partition "system" using LBA of 129024
Size determined from zip: 2147483648
Partition will occupy 4194304 sectors
Processing partition "oem" using LBA of 4323328
Size determined from zip: 536870912
Partition will occupy 1048576 sectors
Processing partition "userdata" using LBA of 5371904
Processing dynamically sized partition "userdata"
Partition will start at LBA 5371904
Remaining sectors on drive: 25744384
Starting step 4 : Writing MBR
Partitions in MBR:
Partition 0 bootable true LBA 2048 size 126976
Partition 1 bootable false LBA 129024 size 4194304
Partition 2 bootable false LBA 4323328 size 1048576
Partition 3 bootable false LBA 5371904 size 25744384
Finished step 4 : Writing MBR
Starting step 5 : Writing file
Using zip file "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer/rpi3-v0.6.1/boot.zip"
Finished step 5 : Writing file
Starting step 5 : Writing file
Using zip file "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer/rpi3-v0.6.1/system.zip"
Failed writeRaw: 0
Tried to write 8388608 bytes
error in mz_zip_reader_extract_to_callback
Failed extracting zip file: write calledback failed
Failed unzipping file
Failed writing partition content for "system"

Comments

  • Official log file from tool below from attempt to install image v0.6.1

    +00:00 (, 0) Starting emteria installer v0.6-16-gc6254ca
    +00:00 (, 0) Detected SSL support: true
    - runtime version: "OpenSSL 1.0.2q 20 Nov 2018"
    - build version: "OpenSSL 1.0.2j 26 Sep 2016"
    +00:34 (, 0) Opening remote connection
    +01:02 (, 0) Refreshing drives
    +01:03 (, 0) Ignoring system drive "xxx"
    +01:03 (, 0) Found 1 drive(s)
    +01:25 (, 0) Checking for OEM config
    +01:26 (, 0) No OEM config available
    +01:26 (, 0) Started downloading "package.json"
    +01:26 (, 0) Using path "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer/rpi3-v0.6.1/package.json"
    +01:26 (, 0) Finished downloading "package.json"
    +01:26 (, 0) Started downloading "boot.zip"
    +01:26 (, 0) Using path "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer/rpi3-v0.6.1/boot.zip"
    +01:29 (, 0) Finished downloading "boot.zip"
    +01:29 (, 0) Started downloading "oem.zip"
    +01:29 (, 0) Using path "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer/rpi3-v0.6.1/oem.zip"
    +01:29 (, 0) Finished downloading "oem.zip"
    +01:29 (, 0) Started downloading "system.zip"
    +01:29 (, 0) Using path "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer/rpi3-v0.6.1/system.zip"
    +01:56 (, 0) Finished downloading "system.zip"
    +01:56 (, 0) Finished DownloadWorker
    +01:56 (, 0) Flashing on raw "\\\\.\\PHYSICALDRIVE1"
    +01:56 (, 0) Initializing package base at "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer\rpi3-v0.6.1"
    +01:56 (, 0) Drive: "Generic STORAGE DEVICE USB Device" with 15931539456 bytes
    +01:56 (, 0) Raw at "\\\\.\\PHYSICALDRIVE1"
    +01:56 (, 0) Starting step 0 : Reading package
    +01:56 (, 0) Finished step 0 : Reading package
    +01:56 (, 0) Starting step 1 : Verifying files
    +01:57 (, 0) Finished step 1 : Verifying files
    +01:57 (, 0) Starting step 2 : Preparing
    +02:00 (, 0) Diskpart output: "\r\nMicrosoft DiskPart version 10.0.16299.15\r\n\r\nCopyright (C) Microsoft Corporation.\r\nOn computer: user1-MOBL1\r\n\r\nDisk 1 is now the selected disk.\r\n\r\nDiskPart succeeded in cleaning the disk.\r\n\r\nPlease wait while DiskPart scans your configuration...\r\n\r\nDiskPart has finished scanning your configuration.\r\n"
    +02:03 (, 0) Finished step 2 : Preparing
    +02:03 (, 0) Starting step 3 : Opening to write
    +02:03 (, 0) Finished step 3 : Opening to write
    +02:03 (, 0) This drive seems to have 31116288 sectors
    +02:03 (, 0) Found 4 partitions to write
    +02:03 (, 0) Processing partition "boot" using LBA of 2048
    +02:03 (, 0) Size determined from zip: 65011712
    +02:03 (, 0) Partition will occupy 126976 sectors
    +02:03 (, 0) Processing partition "system" using LBA of 129024
    +02:03 (, 0) Size determined from zip: 2147483648
    +02:03 (, 0) Partition will occupy 4194304 sectors
    +02:03 (, 0) Processing partition "oem" using LBA of 4323328
    +02:03 (, 0) Size determined from zip: 536870912
    +02:03 (, 0) Partition will occupy 1048576 sectors
    +02:03 (, 0) Processing partition "userdata" using LBA of 5371904
    +02:03 (, 0) Processing dynamically sized partition "userdata"
    +02:03 (, 0) Partition will start at LBA 5371904
    +02:03 (, 0) Remaining sectors on drive: 25744384
    +02:03 (, 0) Starting step 4 : Writing MBR
    +02:03 (, 0) Partitions in MBR:
    +02:03 (, 0) Partition 0 bootable true LBA 2048 size 126976
    +02:03 (, 0) Partition 1 bootable false LBA 129024 size 4194304
    +02:03 (, 0) Partition 2 bootable false LBA 4323328 size 1048576
    +02:03 (, 0) Partition 3 bootable false LBA 5371904 size 25744384
    +02:03 (, 0) Finished step 4 : Writing MBR
    +02:03 (, 0) Starting step 5 : Writing file
    +02:03 (, 0) Using zip file "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer/rpi3-v0.6.1/boot.zip"
    +02:08 (, 0) Finished step 5 : Writing file
    +02:08 (, 0) Starting step 5 : Writing file
    +02:08 (, 0) Using zip file "C:/Users/user1/AppData/Local/Emteria/Emteria.OS Installer/rpi3-v0.6.1/system.zip"
    +02:36 (, 0) Failed writeRaw: 0
    +02:37 (, 0) Tried to write 8388608 bytes
    +02:37 (, 0) error in mz_zip_reader_extract_to_callback
    +02:37 (, 0) Failed extracting zip file: write calledback failed
    +02:37 (, 0) Failed unzipping file
    +02:37 (, 0) Failed writing partition content for "system"

  • Use Windows 7

  • edited March 12

    What Windows version? Is it an external sdcard adapter?

  • dubdub
    edited March 12

    @kalkov said:
    What Windows version? Is it an external sdcard adapter?

    Windows 10 64bit only.
    USB to microSD adapter. No internal SD a lot on this PC. .

  • I have the same setup with an old HAMA USB 2.0 card reader and no issues so far.

This discussion has been closed.