Raspberry Pi 4 – Official 7” Touch Screen

I tried nightly 11.0.9 and beta version 11.0.0. With both versions the touch screen was initialized (Rainbow square and backlight) but not used.

If a HDMI display is connected, the device starts on it without using the touchscreen.

Did anybody managed to get the official 7” touch screen to work?

Tagged:

Comments

  • Hi @Michael_ZPF, currently we only support HDMI displays. The DSI connector isn't integrated, yet.

  • Thanks @smieschek for the fast response,
    Is there a place where all already integrated functions and features are listed for the RBP4?

    Do you have a timeframe for the support of the DSI connector (tomorrow, next week, next month, next year, …)?

    Thanks,
    Michael

  • edited April 21

    Hi @Michael_ZPF ,
    There are two sources for these information. On the one hand we have our release notes where the integrated functions are listed. On the other hand we have our knowledge base where we collect known issues and frequently asked features which are not integrated, yet.

    DSI connector is pretty high on our priority list, but it's rather next month than next week.
    I don't know if I get you right, but just to make it clear. You will get an image either via DSI or HDMI. I don't think it will be possible to have both activate at the same time.

  • Hi @smieschek ,

    I am eagerly waiting when Rasberry pi official display will also be supported for Pi4 . Wish would be if we can support both at same time .If not possible can the design be intelligent enough to check if Hdmi is available and switch to HDMI otherwise check if DSI is available and pick DSI .

    Thanks and appreciate your hard work.

    With regards,
    Saurabh

  • edited May 2021

    I am also interested in the progress of the Pi4+touchscreen feature. I used the latest Beta for the Pi 4 with effectively the same results as the original post. The OS looks really promising so far...eager to put it to use.

  • Hi,

    any news on this? Does the display already work with the actual release 11.2.0?

  • Hi @Michael_ZPF , @Pandey , @crmann and @bgers
    It was great effort, but I have good news. We have an implementation of the DSI connector on Android 11 for RPi4. Starting with nightly v11.2.20 the official 7" touchscreen, and possibly others, should work. Please give it a try, I'm very much looking forward to your feedback.

  • Hi @smieschek,

    already installed it. Looks good at the moment.
    Thank you!

  • For the first test I only connected the 7” touch screen, but execution stopped (or at least there was no further feedback) after “Starting kernel ...”

    Same result after reset. Test made on RB4 2GB.

  • @Michael_ZPF said:
    For the first test I only connected the 7” touch screen, but execution stopped (or at least there was no further feedback) after “Starting kernel ...”

    Same result after reset. Test made on RB4 2GB.

    V 11.2.21 resolves the problem.
    The RB boots to the 7" touch screen and passes the Android config steps ...

  • Thanks for the feedback and glad to hear that it works!

  • Hi,
    Does Somebody knows If the Emteria.OS is somehow related to "old" RTAndroid? Asking because thinking about update from RPi3 + RTAndroid (7" Touchscreen) to RPi4 Emteria.OS (7" Touchscreen) - tryed few month ago but DSI was not working that time

  • edited August 2021

    @Pityuka, they are not related in terms of the codebase, but they relate through my person, who started both, RTAndroid project and the emteria company. But this is an off-topic here I think.

  • Hello, I have a question about the DSI display.
    With a Raspberry 3B the original 7 "display works perfectly. With a Raspberry 4B the display jerks a lot. It doesn't run smoothly!
    The following comment is displayed by the operating system:
    "Serial console enabled. Performancs is impacted. To disable, check bootlader."
    Where do I have to turn something off or where can I find it. I would be very grateful for a tip.
  • Hi @Edison ,
    You are right, the image through DSI is a little shaky at times. We are actively working on that, but unfortunately I don't have an ETA for an update in that regard.

    To get rid of the notification you can remove the line "enable_uart=1" from the config.txt on the boot partition.

  • Hi, where can I find the version 11.2.21 ? I have tryed the latest live version with rpi 4b and 7" dsi touch but after a rainbow i onlye get a black screen.

  • edited April 21

    Hi @Ozi ,
    Please give the exact version you are using. With daily nightlies "the latest" version is too vague. But I'm also using 11.4.20 and official RPi touchscreen works. Do you have any other peripheral connected? Otherwise please provide UART log: https://emteria.com/kb/connect-uart-rpi

  • Hi, I am using a HQ Camera and a 7" touchscreen on my raspberry pi 4 model b with nightly 11.5.3 .The camera works connected via hdmi but when i try to connect the touchscreen, after the rainbow i get blackscreen and the green led is off. Is there some driver missing in the config.txt?

  • Hi again,
    the touchscreen issue came from a power supplie not strong enogh. I now got the screen working but the touch does not. After startup, the first touch i do gets freezed, like if im not taking my finger off the screen.. please help me

  • hi @Purdbull ,
    Do you have the same behaviour without any other peripherals? (e.g. try without the HQ Camera)
    How do you power the touchscreen now? Is it the official RPi Touchscreen connected via DSI?

  • Somewhat similar but different, having issue with touch on the pi4 running rpi4-v11.5.11with official 7in. completes setup and reboots. Boots fine, looks good, but then it seems the touch sensor is continuously triggered and will not allow input. Anybody seen this?

  • @piology yes, we've got a few bugreports about this, but were not able to reproduce it with devices in our lab. Do you have any peripherals connected? Does it always behave like this? What version of the touchscreen do you use?

  • edited February 8

    @smieschek Awesome, happy to help with some root cause analysis.
    No accessories, just the pi 4 B and 5V and ground wires to the PI pin 4 and 6 and the v1.1 display ribbon cable.

    I have 3 sets, fresh off Amazon all doing the same thing. Running nightly 11.5.11

  • @piology I see no difference to my setup.
    Do I get you right, that the touch works fine after your first boot and that you can go through the setup wizard, but after another reboot the touch doesn't work?
    Have you provisioned any settings? Do you activate the device during setup wizard?
    Can you connect a mouse when the touch doesn't work and go to emteria settings to send a bugreport?

  • That is correct. Touch sort of works during initializing, laggy response, so I did connect USB keyboard with touchpad and it worked fine. No jittering or rapid fire recent apps Device activation during the setup is done.

    When it's rapid fire touch sensing after boot I cannot navigate anywhere. Is there boot interup option to run in debug mode?

  • So I also tried the live build and the display just looks like a zebra.

  • On nightly 11.5.13 the system boots into setup, screen is stable, but the touch doesn't work at all

  • @piology do you have a UART bridge?
    Please contact support@emteria.com and we can schedule a live debug session

  • We've patched the touch driver since nightly 11.6.19
    If you were having issues with the touch events, please try that nightly. It will also be included in the upcoming release.

Sign In or Register to comment.