Bluetooth not working on rpi 3b+

I have just installed android 7.1.2 on a rpi 3b+. Bluetooth wont turn on, and thus is not useable. Am I missing something?

Comments

  • edited April 21

    Hi @Kevin ,
    Unfortunately, that's a known issue on RPi3: https://emteria.com/kb/known-issues-rpi3b

    There are a few forum discussions on the reasons and I must admit we don't plan to put further effort into Bluetooth on RPi3. If your use-case relays on Bluetooth, your best bet is to switch to RPi4.


  • Thank you for your reply. Yes bluetooth is important for me. I am building a car satnav and music player using OSMand mapping. OSMAnd works great on my RPI3, phones and android tablets, but wont run on rpi4 emteria v11.4.0 . It shows a strange corrupted screen. Screen shot attached.

  • @Kevin Is the screen like that only in the app or also for the homescreen?

  • Thank you for your reply. Yes bluetooth is important for me. I am building a car satnav and music player using OSMand mapping. OSMAnd works great on my RPI3, phones and android tablets, but wont run on rpi4 emteria v11.4.0 . It shows a strange corrupted screen.

  • Just this app, other apps seem to work ok, but settings such as screen rotation aren't remembered after power off, and sound quality playback through microphone socket is poor. The rpi3 seems to work much better than the rpi4, except for the bluetooth, which does work fine on the rpi4.

  • @Kevin Screen rotation is something we are aware of and currently tackling. I know that VNC looks off, if you start it and rotate the screen afterwards. This might also be the case for OSMand. When the screen rotation is persistent, this issue might disappear after a restart, but no guarantees.

    Haven't heart of any sound quality issues. Can you describe it a little bit more? Do you have an HDMI or DSI display connected?

  • @Kevin We changed a few things in that regard, which might have helped. Can you try with nightly v11.4.10 please?

  • I tried nightly builds v11.4.10 and v11.4.12 and neither would boot on my rpi4.

  • @Kevin Sorry for the inconvenience, but can you try again with v11.4.16?

  • Just tried v11.4.16 on two different rpi4s, wouldn't boot on either. One is connected to a vdu, other to official rpi 7" touchscreen

Sign In or Register to comment.