Rpi 4B + Waveshare 7.9" simply cannot see Emteria boot logo

Hi folks - 22nd straight hour of troubleshooting (4 hours per day since last Wednesday) and I'm at wit's end. Some help would be much appreciated.

I have a RPi 4B 8GB and the reportedly supported Waveshare 7.9" display. No matter what I try, I simply cannot get to the Emteria boot logo. FWIW, The basic Raspberry Pi Debian build works flawlessly after adding the Waveshare HDMI lines to config.sys.

Here's what I've tried:

In this thread, in the second comment, OP says he has same setup as me. He says

In addition to this I want to add that the same RPI [4B] with the same Emteria.OS [11.3.0] installed on it works well with my PC's screen and with another Waveshare screen (with this one https://www.waveshare.com/7.9inch-hdmi-lcd.htm ) and does it out-of-box.

(a) I tried the same thing: flash from tool > eject > + boot from SD card
upon applying power, a distorted rainbow shows up, which fades out and stays black.

(b) I added the Waveshare code at the bottom of config.sys
hdmi_timings=400 0 100 10 140 1280 10 20 20 2 0 0 0 60 0 43000000 3
Better! upon applying power, a single clear rainbow square shows up, followed by a fast scroll of text (with 4x raspberries on top), but immediately after this, the screen turns black (presumably here is when the Emteria logo should have shown).

(c) I commented out dtoverlay=vc4-kms-v3d-pi4,noaudio
The same text scrolling shows up, but is slower and continues infinitely like OP states in the thread above

(d) I un-commented the line and added an F for fake kms to make dtoverlay=vc4-fkms-v3d-pi4,noaudio
Same result as (c).

(e) I went back to (b) and kept dtoverlay=vc4-kms-v3d-pi4,noaudio but commented out disable_fw_kms_setup=1
Same result as (b).

Now when I look at config.sys, mysteriously, my timings line has disappeared from the config.sys and a cma-256 has shown up before noaudio in the kms line

(f) I added the timings line again, kept dtoverlay=vc4-kms-v3d-pi4,cma-256,noaudio untouched and disable_fw_kms_setup=1 commented out
A clear rainbow square shows up, followed by the infinite scrolling text BUT the text is interlaced and unreadable.

I've tried versions 11.8.0, 11.6.0, 11.5.0 with all variations above. I think I have close to 400 boots on my raspberry pi at this point, which is probably bad for its electronics, so before I fry the components - what can I do to get this to boot?


  • @smieschek , any input you can provide on this would be much appreciated.

  • @absolutk Thanks for the detailed description of what you have already tried. I suspect the display is similar to the official touchscreen and your changes in the dtoverlay from kms to fkms are reverted, but the display doesn't work with kms. Long story short: revert all your changes to the config.txt
    Recommended way would be to use provisioning to set persist.rpi.vc4.force to fkms, see https://emteria.com/kb/introduction-to-device-provisioning#system-properties
    If you don't have a premium subscription and cannot access provisioning, you can do it manually.
    There are two options:
    If you have a UART, disconnect all displays and boot into headless. In console you can setprop persist.rpi.vc4.force fkms.
    If you don't have a UART, connect an HDMI display to get it booting and enable adb in emteria settings. Then you can access console with adb shell and set the property.
    Afterwards disconnect the HDMI screen and connect the Waveshare display again and try booting.

    It might be that you will still need these changes in the config.txt:
    hdmi_timings=400 0 100 10 140 1280 10 20 20 2 0 0 0 60 0 43000000 3
    But I would first try just with forcing fkms.

    Sorry for the complicated workaround. The problem with changing the config.txt is, that they will be overwritten on an OTA update so that we are using properties instead. We are working on the possibility to have a custom config.txt uploaded, but that's not live yet.

Sign In or Register to comment.