Amoled screen 5,5" Display problem on RBpi4B

Hello,

I bought this amoled screen that is designed for Raspberry pi 4B 8GB: https://www.waveshare.com/5.5inch-HDMI-AMOLED.htm

I have tried all possible versions of Android for Raspberry (LineageOS, Omnirom, Raspand) and Emteria OS now but all Android OS have the same problem, i.e. display is not supported load for this screen.
I tested on my tv screen and Android works well.

I have tried to find the solution which should probably be to add something to the config.txt file but no one so far has been able to help me, also on all forums. If you have a solution for me that would be great!

Thanks for your help,

Comments

  • Hi @Otherness ,

    Have you followed that guide: https://www.waveshare.com/wiki/5inch_HDMI_AMOLED
    It states, like you suspected, the following changes to config.txt:

    disable_overscan=1
    max_usb_current=1
    hdmi_group=2
    hdmi_mode=87
    hdmi_timings=960 0 190 4 32 544 0 10 10 12 0 0 0 60 0 41000000 3
    
  • edited January 20

    Hi!

    I also met some problems with this screen.

    I tried to connect it to a RPi4B 4Gb with Emteria.OS 11.3.0 installed. While booting the latter gets stack at some moment and repeatedly outputs messages shown on the pictures attached. As you can see, sometimes these messages saying something about "zygote_secondary" service, sometimes -- about "cameraserver", "media" and "wificond" services.

    To fix it I tried to follow official guide from Waveshare concerning this screen (https://www.waveshare.com/wiki/5.5inch_HDMI_AMOLED ) and inserted these lines of settings:

    max_framebuffer_height=1920
    max_usb_current=1
    config_hdmi_boost=10
    hdmi_group=2
    hdmi_force_hotplug=1
    hdmi_mode=87
    hdmi_timings=1080 1 26 4 50 1920 1 8 2 6 0 0 0 60 0 135580000 3
    

    to the end of boot/config.txt file but it didn't help. The only profit it had given that RPi began to use correct resolution of the screen from the very beginning of the boot process and not after few seconds after it how it had been previously.

    In addition to this I want to add that the same RPI with the same Emteria.OS installed on it works well with my PC's screen and with another Waveshare screen (with this one https://www.waveshare.com/7.9inch-hdmi-lcd.htm ) and does it out-of-box.

    I can try to provide additional information if you need so!

    Thank you all for your attention and looking forward for your help!

    PS Sorry for bad quality photos :(

  • hi @AntonovE ,
    The quickest thing you can try is to install beta v11.5.0
    We changed quite a few things regarding graphics between 11.3.0 and 11.5.0 and it might just work.

  • @smieschek Thank you for the advice!

    I tried to update my system from v11.3.0 to v 11.5.0 by switching to the Beta level of allowed updates in the Emteria's settings and performing an update by clicking on an appropriate button in the same menu after it. The result is that the system was updated and my 5.5' screen began to work. But in the same time another problem appeared - the display/image began to flicker. It didn't do it while standing still but, if you touch the screen causing movements of some elements of a GUI, a few flickers appeared some time after it. Also it should be mention that all other screens that I tried to connect to the Raspberry with updated Emteria.OS suffered from this problem.

    As the second step I tried to make a fresh install of v11.5.0 Emteria on a SDcard using Emteria Installer. The result: flickering dissapeared but the 5.5' screen became unworkable again with the same set of symptoms as shown on the pictures above.

  • @AntonovE I suspect that this issue is not related to the display. Might be similar to: https://forum.emteria.com/discussion/1088/passpointmanager-causing-boot-loop
    Do you know if there is a Hotspot in your proximity?

Sign In or Register to comment.