Boot stuck on init with official screen

edited October 2019 in Installer

As per the thread title,

I have flashed the SD card in Win 10. Using Pi 3 B+ with official touchscreen.

The boot process is hanging at init: Starting service 'exec 11 (system/bin/bootstat/)'...

I re-flashed the sd card and started from scratch and get exactly the same result.

Anyone any advice?

Edit: To rule things out, I've installed and run Raspian with no problems. I've also tried different power configurations and I don't believe this is an issue.

Comments

  • edited August 2019

    @kalkov any ideas? Just to clarify that this is when I've successfully flashed the sd card and I am trying to boot up the pi for the first time with Emteria... during the boot process, it hangs after the above terminal output

    What is happening during the boot process at this point that could help debug the issue?

  • edited August 2019

    I had similar problem in two cases - after system update and after system restore. I wrote about it here: https://forum.emteria.com/discussion/comment/2935#Comment_2935.

    If I remember correctly, I saw message "init: Starting service exec..." too but in addition, there was couple of "binder: X:Y transaction failed..." messages around. Do you see them too?

  • Thanks @Martin. I haven't noticed those messages but I will look again. This is happening me with a freshly flashed sd card (I tried re-flashing twice).

  • @Di11on have you tried HDMI connected display? In my case, it is only DSI display not supported, which means sadly Raspberry Pi's official touchscreen stops working with this version.

  • Mh, strange. Will check it tomorrow.

  • edited August 2019

    @fishred008 are you suggesting that if I install a previous version, DSI would work? If so, what would I be missing, not having the latest version?

  • Feel free to compare the versions here:
    https://emteria.com/Home/ReleaseNotes

  • I confirm that 0.7.1 is working but 0.8.1 fails to boot with the official Raspberry Pi 7" touchscreen (using DSI).

  • @Di11on said:
    I confirm that 0.7.1 is working but 0.8.1 fails to boot with the official Raspberry Pi 7" touchscreen (using DSI).

    Yes, i also fell back to 0.7.1

  • edited September 2019

    @Di11on I can also confirm the same issue you are having. I have moved to 0.7.1 and can confirm that everything works great.

    If anyone can test 0.8.0, we can isolate where this regression happened.

    @kalkov I see the following changes (idk if this helps)

    v0.8.0:
    Updated screen resolution detection to reuse existing modes

    I hope it gets fixed!

  • hello all, could someone tell me how to flash the SD with version 0.7.1? I have the same issue with the latest version but, can't find the previous versions of the installers. Thanks

  • edited September 2019

    Same Problem here with official display....!

  • I am also having the exact same issue with the 7 inch official touchscreen on 0.8.1

  • Exactly the same for me.
    rpi 3+ with official rpi 7" display and Sw -license freshly organized.
    How may we help for this issue?
    I'm ready to give more info if someone give some commands or actions to apply.
    cheers

  • Please could someone tell when is the next version output of emteria organized ?

  • hello guys, i do a retry today, i didn'T change anything , on replug ma rpi 3+ again and work through like a charm.
    Have a good success.
    cheers

  • Sorry guys, I was out of office for a while and it looks like we had an issue with the official touchscreen. It is fixed now and we will be releasing a new version ASAP.

  • hi there.
    just trying to do some testing on my rpi3b+ with emteria os 1.0.0 and it hangs on:

    init: Starting service 'exec 13 (system/bin/bootstat/)'...

    tried few time with repluging rpi, and couple of times reflashing sd card. no luck.

    im using official 7" touchscreen

  • You have to connect a display with hdmi, then you will see the android screen.
    In settings you must change the resolution of the monitor.
    Merry Christmas

  • Same problem here. Emteria 1.0.0 does not boot with RPi 7" display. Booting ok when HDMI display is connected. I tried to change resolution in Android RaspberryPi settings, but there is no option for 800x480 resolution. I put an expected resolution to be 800x480 60fps and reboot with RPi 7" display. Boot hanging, no luck.

This discussion has been closed.