Starting kernel... hang out

edited January 2018 in General

Hi!
I try to install version 0.5.2 on RPi 3 v1.2 with Windows and Ubuntu. On both the same result. Try different adapters.
Try read serial from RPi but it doesn't transmit anything. Just hanging out on "Starting kernel...".

Interesting is that LED on RPi still blinks.

Net: No ethernet found.
starting USB...
USB0: Core Release: 2.80a
scanning bus 0 for devices... 4 USB Devices(s) found
scanning usb for storage devices... 0 Storage Device(s) found
Hit any key to stop autoboot: 0
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot.scr.uimg
reading /boot.scr.uimg
401 bytes read in 17ms (22.5 KiB/s)

Executing script at 02000000

reading zImage
7472872 bytes read in 408 ms (17.5 MiB/s)
reading ramdisk.uimg
1547931 bytes read in 109 ms (13.5 MiB/s)
Kernel image @ 0x1000000 [ 0x000000 - 0x7206e8 ]

Loading init Ramdisk from Legacy Image at 02100000 ...

 Image Name:
 Image Type: ARM Linux RAMDisk Image (gzip compressed)
 Data Size: 1547867 Bytes = 1.5 MiB
 Load Address: 00000000
 Entry Point: 00000000
 Verifying Checksum ... OK

Flattened Device Tree blob at 2effb300

 Booting using fdt blob at 0x2effb300
 reserving fdt memory region: addr=0 size=1000
 Using Device Tree in place at 2effb300, end 2f002faa

Starting kernel...

Comments

  • I have the same problem. Tested with 2 Pi Model 3B and different Screen options in the config.txt.

  • One time it worked with the fkms overlay in the config.txt But with flickering display.

  • edited January 2018

    @kalkov , could it be hardware revision?

  • With version0.5.3 exactly the same problem

  • Version 0.5.4 solved problem. But recovery mode not starting. The same problem as before - hangs on Starting kernel...

  • This is really strange. Sorry, I have no idea why this problem occurs.
    Does 0.5.4 work correctly all the time? Or does it sometimes boot and sometimes doesn't?

  • BTW: what screen are you using? What other devices are connected?

  • 0.5.4 boots every time. Recovery boot doe'sn boot at all.

    Nothing else connected. Only screen, some Logitech mouse.
    Tried with several 24" monitors like LG and Dell, each connected through different HDMI cables.

  • @Wiktor, I can't come up with a reasonable explanation for that. I am really sorry.
    It doesn't make a lot of sense to me, as both systems (emteria.OS and recovery) use the same kernel.
    Is there any chance you can record boot logs (https://elinux.org/RPi_Serial_Connection)?

  • Did you change the original cmdline.txt?

  • I had the exact same issue. I installed 0.5.5 . I left it for the whole night and work day. When I got home tonight I discovered I was in the Recovery screen. Did what I needed to and restarted. The second time I booted into Recovery mode it was lightening speed.

    Can someone else test if leaving it, for say 24 hours works?

  • Ok, My previous comment was a once off until I reloaded the latest Emteria image (0.5.6)

    I have the same problem when booking into recovery mode. It just hangs.

    Here is my cmdline.txt details

    dwc_otg.lpm_enable=0 console=tty0 console=serial2,115200 root=/dev/ram0 elevator=deadline fsck.repair=yes rootwait no_console_suspend earlyprintk androidboot.hardware=rpi3 androidboot.selinux=permissive audit=0

  • Sorry, I lost the track. So with 0.5.6 you are not able to enter recovery mode, is that correct? But the system is working just fine?

  • Should Raspberry transmit anything on UART during boot Emteria? Is baudrate 115200 correct? Is there any special way to enable uart transmission in emteria?

  • It is disabled by default. You need to change the "console" line to "serial0" in cmdline and add "enable_uart=1" to config.

  • Hello. I have the same issue. Raspberry pi 3 b + is not booting in to recovery mode. Even with new installation of 0.6.4 version. What can I do?

  • Any update on this issue ? I am too facing same issue. Using Raspberry pi model B

  • Connect a serial cable and check system logs. There is no point in guessing.

Sign In or Register to comment.