Changing screen resolution

edited January 2019 in Supported devices


is it possible to change resolution of screen to 1080p?
Maybe before writing the image or even after installation in config.txt of rPi3?




  • edited January 2019

    Yes, it is possible, but I wouldn't recomment you doing this, as it makes RPi3 slow and may introduce crashes. You need to change two files:

    1) /boot/config.txt
    2) /system/build.prop

    In both files, you will find the hardcoded 1280x720 resolution. Just change it to whatever you wish (in this case you also should set to 0).

  • edited September 2017

    Hi kalkov,

    thanks for your quick response!

    Sadly my rPi booted up but with blank screen.
    After title "Android" appeared on screen it changed to black :neutral:

    I'll try some more settings with refresh rate...
    Do you think this misbehaviour is based on wrong settings in config.txt or in build.prop?

  • Sure, wrong settings can cause a lot of different issues. Please make sure that your monitor/tv/touchscreen supports the resolution you have set and that values in both files match up.

  • My display is running quite lo res and does not have anything relating to 1280 x 720. Am I correct that I need to set framebuffer_width and height to change resolution ?

  • No. It depends on what you really want to achieve. Since the official touchscreen only supports 800x480, emteria.OS adjusts the output automatically. If you would like to enfore a higher resolution (it would mean Android has to recalculate the picture on each change, which might be very expensive in terms of RAM and CPU time), you need to set it in the Android shell. For example, using the ADB shell:

    wm size 1280x720

    Keep in mind following commands:

    wm size reset
    wm density 160
    wm density reset

  • Hi

    I need to run my rPi3 on a 19" screen with a 5:4 aspect ratio in Portrait mode.

    I have played with various settings and none of them seems to work.

    1) /boot/config.txt
    hdmi_cvt=1280 1024 60 4 0 0 0
    initramfs ramdisk.img 0x01f00000

    2) /system/build.prop

    Changes explained:
    hdmi_cvt=1280 1024 60 4 0 0 0

    desired resolution is 1280x1024
    Frames per second is 60
    Aspect ratio is 4, which translates to 5:4

    This is to flip the screen by 90 degrees

    I am experiencing the following issues:
    1. The screen doesn't flip - it is still in landscape mode
    2. I get an error "SlimLauncher has stopped" and then just a black screen.

    Please advise how to best resolve the two issues listed above.


  • Don't use "display_rotate". If you need a rotated screen, use one of the available apps for Android like "RotationControl". We have also replaced the SlimLauncher with the official Google launcher - it will be available in the next release (1-2 days). Maybe it will fix your problems.

  • Hallo, ich habe über das command die Bildschirm Auflösung auf 1280x1024 geändert. Jetzt habe ich ein 4:3 ich habe aber ein Bildschirm der 4:5 bzw. 16:9. Wie ist der command dafür das zu ändern. Ich bekomme es nicht hin die config.txt zu editieren. LG

  • Hello, I changed over the command the screen resolution to 1280x1024. Now I have a 4: 3 but I have a screen of 4: 5 or 16: 9. How is the command for that to change. I can not get it to edit the config.txt. LG

  • How do I access the /boot/config.txt and /system/build.prop?

  • For example you can mount your sdcard on a Linux PC.

  • I don´t have Linux Pc and in windows I can´t access the sd card after installing android via emteria installing software.

  • There is currently no other way of changing the initial resolution.

  • The OpenROV Trident Cockpit app is streaming RAW h264 1280x720 video at 30 fps using RTI DDS. The Cockpit instrument data is displayed fine, but not the video. Other Android devices using the app display the video fine.

    1) Would changing the 60 fps to 30 fps in /boot/config.txt be expected to make a difference?
    2) The video is displayed in a smaller window, not full screen, so could there be some video scaling issue?
    3) Or could some support for RTI DDS be missing in emteria.OS?

    I don't have the Trident to test with yet and the person who was testing the app on emteria.OS can't edit the config.txt.

  • Please see the system logs for errors, since I am very bad at guessing why it isn't working.

    1) No. Unless it is a memory issue and you reduce the resolution.
    2) Depends on the application.
    3) Idk, what kind of support is required?

    What is the problem with editing the config file?

  • Hi. can not adjust screen 800 * 480
    on HDMI on the monitor it turned out,
    but on the screen in the car, through the HDMI adapter in the RCA screen does not show anything.
    On the TV set, the HDMI screen is black.
    here written by
    it is necessary to replace = 1 on 0
    but the config does not have debug.drm
    help please make a config for 800 * 480 and if possible which is better through the RCA output
    Thank you.

  • Which version do you use? In the latest version there is an option in Settings -> Raspberry Pi to request a different resolution without modifying any files.

  • @kalkov , it seems my same problem... The resolution apparently changes even if the dots for pixels remain the same. Except for the boot, that one perfectly follows what is proposed by the config file.
    Unfortunately the video because of the commitments I could not do it.
    I look if I can tonight.
    I am sorry.

  • When I try to change the default 1280 x 720 screen resolution (in order to see desktop items on the top of the screen), in the raspberry pi settings, I loose video after reboot and have to format and reinstall the os in order to get it back.
  • I wanted to use RPI3 with emteria Android on my Samsung TV, but when booting I see only black screen. My tv is quite old and its resolution is - 1366 x 768 . Is it any possibility to change resolution before booting, to start it with compatible with tv res?

  • @Dan, if you see no video output after a reboot, your TV/monitor doesn't support the chosen resolution. What do you mean by "to see desktop items on the top of the screen"?

    @Hvil, no, you need a working TV or monitor for the initial setup. Our automatic provisioning options contain a possibility to setup the desired initial resolution before the first boot, but they are only available for business customers.

  • I have issues setting up a fixed resolution on my RaspberryPi 3 Model B+ (Plus)
    It seems like some things have been changed since this post.
    /boot/config.txt has a slightly different order, but /system/build.prop is a much harder problem because I don't have write access without changing it manually, and when I safe the changes, it refuses to boot. So I tried adifferent method, just changing /boot/config.txt and set hdmi_mode to 35 which is 1280x1024@60Hz and dtoverlay to vc4-fkms-v3d,cma-256, the first time I booted everything worked fine, but the second time my old VGA monitor displayed nothing, when I plugged it into my FullHD TV everything worked, but when I change it back, plug it into the TV to test the settings, and it start to load Android, the Pi resets the output to 1080p. It's my first RapberryPi so I'm still learning and could need some advice, especially how to set it up that it always boots in 1280x1024
  • @webfischi, you shouldn't be changing the resolution manually. Check Settings -> Raspberry Pi for different resolution options.

  • Dear Igor,

    I have a HP LP2475w screen connected via HDMI to a raspberry pi3. This screen has a recommended resolution of 1920x1200.

    But if I change this following your directions by going in to the settings screen and change the Settings -> Raspberry Pi to request a different resolution and set this to 1920x1200 and reboot afterwards, the screen goes black and I have no clue how to access the OS again to undo the change and get the screen back.

    Can you give a hint on how to restore the original settings or will I have to reformat the SD card and start all over again?

    Best regards.

  • There is no (simple) way of restoring the original configuration. Reformatting the card is probably the fastest one.

  • @kalkov said:
    There is no (simple) way of restoring the original configuration. Reformatting the card is probably the fastest one.

    That is a problem. So is this problem changing the resolution on raspberry Pi going to be changed in the nearby future?

  • The "problem" is not the changing of the resolution itself - obviously, you had no problems in storing the desired setting. It is rather recovering from an invalid state with no input what so ever, where the user was warned about possible consequences. I am not aware of a possibility to achieve that.

  • Yet another problem - Every difficulty I have experienced with this software has been blamed on someone else. From google having broken VPN functionality to crippling performance on the latest hardware, to no working bluetooth drivers to speak of and inability to hit 1080P (It works in raspbian?), inability to use L2TP VPN (the reason the software was purchased), on and on. Call technical support, they tell you they know it doesn't work, but they will get it working eventually. Tell them you want a refund, you never hear from them again. I don't think we are looking at many independent faults - the problem is the software. Given up on this platform, Emteria technical support, and emteria customer support. I think the issue is that they thought functionality was going to be to achieve, and don't have the engineering/financial resources necessary to fix the mounting problems. Maybe if we come back in a few years, the bluetooth, VPN and the other intended features will be operable, and maybe even responsive. Heck, we might even be able to change the resolution without a reformat! Wouldn't that be novel.

  • @kalkov said:
    The "problem" is not the changing of the resolution itself - obviously, you had no problems in storing the desired setting. It is rather recovering from an invalid state with no input what so ever, where the user was warned about possible consequences. I am not aware of a possibility to achieve that.

    So in other words, your telling him the same thing apple told people - the antenna in their iphone was fine, but the users fat hand was blocking reception. Give us a break. The problem isn't with my car's suspension, sir, its the gaping pothole in the road.

    Maybe instead of some blurb about "Possible Consequences" Industry standard best practice should be applied, and if a user fails to interact with an object oriented confirmation dialog, it reverts/defaults back to its previous resolution. We could maybe spend some money, and implement that common sense measure representative of good practice and common sense, maybe along with working drivers and low level pre boot access, or we can sit here and argue semantics on an internet forum (supposed to be for technical support) about whether or not he can "Change His Resolution" when after he does so it bricks his device, and moreover, his entire install.

    Why haven't reasonable measures been taken to implement working drivers, optimizations and such industry standard best practices? The Answer is simple - the critical mass of requisite engineering expertise and technical resources required to do aren't there - and someone either isn't making enough to hire the help they need, or flat out doesn't care - and honestly believes every user who has these problems are fabricating them from the ether.

  • Hi,
    Is it possible to change the video output to DPI display? I tried to add same commands that I used in config.txt file on Libreelec to set the video output to DPI but the Emteria wont boot. It stays on black boot screen with white text. I mean I get video on the display. But no booting.

  • hii

    can i connect it to a tv with resolution of 1080 p??

  • @Mister_Ed said:

    @kalkov said:
    There is no (simple) way of restoring the original configuration. Reformatting the card is probably the fastest one.

    That is a problem. So is this problem changing the resolution on raspberry Pi going to be changed in the nearby future?

    @Mister_Ed , did you ever find a solution to this? I just did exactly the same :-)

  • edited September 2023

    Just an update:
    I followed some of the recommendations here,, and got it resolved. But to be honest, I'm not sure whether any of them did the magic or just a couple of reboots...

  • This thread is rather old, we've added RPi Settings in the meantime, where you can select available resolutions. No config changes are needed. Also be aware that any changes to /boot will be overwritten on an OTA update. You need to use the dedicated overwrite files to make it persistent

This discussion has been closed.