Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Enable Bluetooth on Raspberry Pi3

Hi,
in order to test my use case, i need to enable the BT connection. Is there a way to enable it? (even if it´s buggy)

Thank you!

«1

Comments

  • You can enable BT by the standard way. Use the button at the top or enable it via settings. We tried it to connect a BT speaker and it works fine.

  • Unfortunately not. The slider can be moved, but does not stay in the enabled position. Device is a brand new Model B+

  • That's strange. When we used it, it worked absolutely fine. But to be honest currently we have connected the speaker via 3.5 directly to the touchscreen.

    I now have tested it here on my test system and BT seems to work fine. I enabled BT via settings and all other BT devices around were found.

  • I know :neutral: tried apps with BT access to enable it but no luck so far. Everything else works like a charm.

  • Bluetooth doesn't currently work on the B+ since it uses a new and different chip from the older B. If you absolutely need it for your application, I'd recommend using the B.

  • Alright, thanks for the clarification. Any chance to see a new build for the b+ soon?

  • It is very high in our priority list, but we can't provide any estimations yet.

  • Hopefully in the near future, have a b+ and need BT, already bought a license ;)

  • edited April 23

    Bluetooth support (RPI 3b+) is keeping me off the os for now

  • Its in our top 5 list. Stay tuned!

  • Is bluetooth problem solved?

  • No, B+ refuses to load the updated firmware. We don't know why.

  • I'm new to the Emteria party - I have an RPi 3B+, and from my understanding BT doesn't work - but is that BT as a whole, or just the onboard BT?

    For my usage, I need BT, but I'm quite happy to just get a BT USB if that's what's needed - so is it BT doesn't work full-stop, or it just doesn't work with the inbuilt BT?

  • Hi! I've the same problem: RPI 3B+ with unsupported on-board BT. Without BT my application is completely useless... idea to solve the problem? Is there a BT usb doongle that is working with 3B+?

  • Hi. Any news on the bluetooth support for the 3B+?

  • anything new to this issue yet? anyone used a bt dongle with success?
  • edited September 5

    You guys need to disable the on-board bluetooth module by adding the following line to config.txt

    dtoverlay=pi3-disable-bt

    After that plug your USB bluetooth dongle & reboot.

    In my case my MSI Bluetooth dongle wasn't working because i assume there is missing driver.
    If any of you had success with his own bluetooth dongle then post feedback here.

  • edited September 6

    The attached logcat assumes that my USB bluetooth dognle is ttyAMA0
    Which is loaded from /etc/bluetooth/bt_vendor.conf
    Is that why it doesn't work?

  • edited September 12

    Hi,
    Regarding all the above replies suggesting to use a USB BT dongle, Is there anyone who actually owns it in order to verify whether it works or not?
    P.S. My USB BT works fine using Raspbian stretch and LibreElec after i disabled the on-board bluetooth the same way i described above.

  • Can we expect any update to the b+? Waiting since april for an bluetooth update... Payed for license, up to now for nothing...

  • @kalkov said:
    It is very high in our priority list, but we can't provide any estimations yet.

    how high is high?

  • @mcpat There are no error messages, so we have no idea where to look for the problem right now :(

  • edited October 8

    It's unbelievable that no one owns a bluetooth USB adapter to give us any feedback whether it works or not!
    @kalkov Is there any plans to make it work?

    Bdw: i been waiting for an answer regarding this issue since October 2017 :neutral:
    https://forum.emteria.com/discussion/comment/238/#Comment_238

  • @roxette

    Hello, which USB bt-dongle do you use? I have adapted the config but have not yet found a dongle that works.

  • edited October 31

    @Mauli, i use MSI bt adapter which works fine using Raspbian & LibreElec after editing the config file.
    It even works flawlessly while playing games using Logitech bluetooth keyboard on EmulationStation & Retroarch.
    However, it refuses to work on Emteria.
    but have not yet found a dongle that works
    This means that you tried many bt adapters but none worked?
    Or you you are still trying to find an adapter that works?

  • edited November 1

    Similarly, there are also problems with the bluetooth module, turned it off in the system, put usb-bluetooth, but also did not see it. Bluetooth is also important to connect to the car radio. the sound comes with terrible stuttering. Even with wi-fi turned off, although it works perfectly. I tried a lot of firmware the same story. See the problem in my pb3. One of these days I will travel around the city to check different usb-bluetooth can help. I thought at first that it was only my problem.

    Ugeen Bluetooth adapter model/

  • edited November 1

    I have doubt that it's missing driver + missing bt HAL as well.
    As it's described in the following logcat
    09-06 02:32:40.996 4268 4284 I bt_vnd_conf: Attempt to load conf from /etc/blu
    etooth/bt_vendor.conf
    09-06 02:32:40.996 4268 4284 D bt_hci : start_up starting async portion
    09-06 02:32:40.996 4268 4293 I bt_hci : event_finish_startup
    09-06 02:32:40.996 4268 4293 I bt_hci_h4: hal_open
    09-06 02:32:40.996 4268 4293 I bt_userial_vendor: userial vendor open: opening
    /dev/ttyAMA0

    It's configured to open /dev/ttyAMA0 only. (for the built-in bt module)
    I was thinking if i can change that in bt_vendor.conf however my bt USB adapter is not recognized because of missing driver.

  • edited November 2

    Here is LibreELEC bt log using the same bt dongle which refuses to work on Emteria, i don't see anything special though :#

    [ 284.816091] usb 1-1.2: New USB device found, idVendor=0db0, idProduct=1967
    [ 284.816105] usb 1-1.2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
    [ 284.853508] Bluetooth: Core ver 2.22
    [ 284.853574] NET: Registered protocol family 31
    [ 284.853579] Bluetooth: HCI device and connection manager initialized
    [ 284.853599] Bluetooth: HCI socket layer initialized
    [ 284.853611] Bluetooth: L2CAP socket layer initialized
    [ 284.853640] Bluetooth: SCO socket layer initialized
    [ 284.867216] usbcore: registered new interface driver btusb
    [ 285.167771] Bluetooth: RFCOMM TTY layer initialized
    [ 285.167797] Bluetooth: RFCOMM socket layer initialized
    [ 285.167814] Bluetooth: RFCOMM ver 1.11
    [ 417.854487] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
    [ 417.854525] Bluetooth: HIDP socket layer initialized
    [ 498.789966] hid-generic 0005:046D:B30A.0002: unknown main item tag 0x0
    [ 498.790474] input: Logitech Cordless MediaBoard Pro(TM) as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0/bluetooth/hci0/hci0:42/0005:046D:B30A.0002/input/input2
    [ 498.793349] hid-generic 0005:046D:B30A.0002: input,hidraw1: BLUETOOTH HID v1.1b Mouse [Logitech Cordless MediaBoard Pro(TM)] on 00:0c:76:71:99:e0
    LibreELEC:~ #

    Edit: when i switched back to Emteria i noticed that the bt dongle is recognized but it just goes in a loop looking for the built-in bt module.

  • I have to admit we are not working on this feature right now, as there were no new hints on why it doesn't work :confused: We are going to update to a new kernel first and re-try loading the BT firmware.

  • @kalkov said:
    I have to admit we are not working on this feature right now, as there were no new hints on why it doesn't work :confused: We are going to update to a new kernel first and re-try loading the BT firmware.

    Which feature do you mean?
    Using bluetooth USB adapter?
    Do you have one to test?

Sign In or Register to comment.